Microsoft Visual C++ Runtime CRASH

I have a desktop computer and a laptop with EXACTLY the same software versions of Cubase and plugins on it, and since cubase 6.05 I am experiencing this weird problem on my laptop: opening files on my laptop that were created or saved on my desktop computer results in a “Microsoft Visual C++ Runtime” CRASH. But only files created with 6.05 comming from my desktop. Files created with older versions of cubase open without problems. If I remove all plugins on my laptop the files open normaly. I’ve nailed down the problems to specific plugins: TubeLimit.dll, Preamp Emulator.dll, CamelPhatFree.dll, TLs_SaturatedDriver.dll, Senderella.dll, FreeverbToo.dll

And now for the funny part: if I create a new file on my laptop and insert these plugins (the ones that seem to make the files comming from my desktop crash) they work normaly. Files from my laptop all work on my desktop. Still have to try what happens if I save these on my desktop and open again on my laptop, will try this later…

And yes, trashed the prefs, re-installed Microsoft Visual C++ Runtime, and so-on. Still not back in business on my laptop on these projects. (desktop and other projects on my laptop runs fine).

I’m out of options here,

Anybody?

kind regards, Jurgen

edit: is it possible it’s a memory-issue? see;
http://www.steinberg.net/forum/viewtopic.php?f=19&t=12651&p=82123&hilit=Microsoft+Visual+Runtime#p82123

edit:
tried re-installing all c++ libs again , did’nt help. tried updating my laptop to cubase version 6.5, no luck. I’ll update my desktop comuter and my sign later…

bump

Upgrade your visual studio runtimes.

I get this error too, but its always when I get close to my RAM limit…

so that’s not part of Windows 7 automatic updates?

Try disabling any programs that execute at your laptop starup.

I believe that you will need to upgrade to 64 bit environment.

It is but is it automatic?

jb, I had a similar problem with big problems even though I had plenty of RAM. It looks like you have 4 gigs of RAM so you should look into doing something called the 3 Gigabyte switch with Windows XP. Do a search and follow the instructions carelully! It worked well for me - I actually did a 2.7 Gig switch but you have to expermiment. Now large projects can still load vsts at well over 1.2 gigs showing for cubase in Windows task manager. Hope this helps…PS as always back up your system before messing with critical setting of your OS!!

OOPS Sorry I realized your laptop does NOT have 4 gigs of RAM. Oh Well

Thanks everyone, not solved yet, but probably a memory issue. What keeps me puzzled is that if I remove the plugs from my vst folder, open the file again, remove the missing plugs from the inserts, then save, re-open WITH plugins in the vstfolder again, then reloading the plugs and plug presets seems to solve this. Doesn’t this point to possible corruption on files from my desktop?

I am running 6.5.1 on W7/64/6 gb memory. I am getting this error when I close a file. It’s really annoying. Plus the slow quitting still persists after what - a year? :frowning: