midex and w8 64bit ?

after all this time to get midex running with a 64bit os on win 7 they only go and release a new blinking os aarrghhhh ,now will the 64 bit unsupported driver work on windows 8 64 bit ? id love to know …oh and thanks for the win 7 64 bit driver anyway it all works fine

+1, if anyone has upgraded already I’d love to know too!

I just installed Cubase 7 on a Win8 64 bit system but I cant get the Midex8 to work.
So I dont know what to do yet.
I might go back to Win7 or I might buy a new Midi-interface, I´ll probably do the first.
Tooooooo bad :frowning:

oh nooooo :frowning:

hopefully the genius who developed the midex-8 driver for win7 upgrades his OS soon :wink:

I’d pay for a supported midex-8 x64 win8 driver btw!

i’ll think i’ll stay on 7 then ,im in no rush for touch technology as a main daw ,that’s what the pads are for :wink:

I tried to do it manually and I manged to install “half” of the drivers. The part for USB Midi.
It failed loading “Fimwareloader”
I dont think that it would take too much time for anyone who knows how to rewrite the it to run on Win8.
But I dont know that for sure of course.

I’ve been using a Midex8 almost daily since soon after the release of Windows 8. Works great!

You on 64-bit as well Elektrobolt?


I had problems with the unsupported drivers on Win 8.1 64 bit, however the old 1903 driver installed fine and seems to be working OK. Note that I ran the 1903 install after I’d tried the new unsupported driver, so perhaps it was 2 step process that got it working.

There’s another confirmation of the unsupported x64 driver working with Windows 8.1 x64 over here.
Haven’t tried them on Windows 8 myself yet, but they work 100% on Windows 7 x64 and the driver model hasn’t changed much between Windows 7 and Windows 8/10 so I expect they’ll continue to work.

Everything went pear shaped last night trying to do some MIDI. Ableton started my EMX1 through the Midex8, then everything promptly stopped. The Midex has disappeared from Win 8.1 and I can’t get it back.

I’m suspecting the hardware may be faulty of flakey.


For the sake of completion,

I got it working smoothly by using the Korg USB driver package (such as the one available for Kronos) to clean out all of my MIDI driver entries (select the advanced option and allow the driver uninstaller to uninstall all hardware) and reinstalled, and it worked first time with the unsupported driver.

Thanks for this information! It would be useful to have a generic utility that would clean out MIDI drivers – perhaps someone knows of such a utility? The Korg USB MIDI drivers “grab” the USB port that the device is attached to preventing any other device from using it. I have no Korg devices so I hesitate to install their drivers.