Midex8 on Windows 10

Hi ther ya’ll,

I was just installing my new computer and sundenly I discovered that my midex8 has not any driver support from steinberg anymore.
Is it time to sell my midex8, or is there an other option of making it work?

Thanks in advance!

Paul (the Netherlands)

See this post for unsupported (but working) drivers:
New unsupported Midex 3/8 drivers available
Yes, it’s a very long post about 6 years old now, but if you look at the last page you’ll see we’ve got it working on Windows 10 as well!


I’m heading to my studio as soon as posible to try!

Many thanks for this reply, I allmost bought a new midi interface. Lets hope I get it to work!



Managed to get it working on WIN10… took some time, cable in/cable out and a few setup runs, but it works!

This spared me like 285- for a new Motu or something.

1 Like


Drivers could be installed on Win10-64 1703 just normal and work like on Win7-64.

BTW: my old Frontier Alphatrack works too…

my midex 8 worked great with cubase 8.5/win10 until recently. I suspect the culprit to be win10 live update. Any plans to update midex drivers to work with latest win10 incarnation?

For anyone wondering: the beloved Midex 8 works still fine here with the “unsupported” drivers on Windows 10 pro X64 v. 1803 :slight_smile:

Long done (since 2011), see this link in my sig: New unsupported Midex 3/8 drivers available
They also work perfectly in 64-bit versions of Windows 10.

I tried this driver on Windows 10 Pro v1903 with no joy. I ran the .EXE and connected the USB cable from my MIDEX8 when prompted. Cubase Pro 10 does not show the MIDEX8 in the MIDI Port settings. I haven’t done any MIDI work in years, but I would like to now. Does anyone have any installation procedure for Windows 10? Or would it be better to buy a new MOTO MIDI interface?

The driver does work on Windows 10 Pro 1903 but I have had problems with some USB ports in the past; it doesn’t seem to like the USB3 ports on my Gigabyte motherboard but works quite happily when connected to a USB 3.1 port (ASmedia chip).

Thanks, MrSoundman. I tried a USB 2 and a USB 3 port on my Asus Z270 chipset board with no luck seeing the device in Cubase. It is visible in the Windows Tray USB devices as Steinberg MIDEX8 (r2), although I cannot eject the device. When shutting down or restarting Windows, the computer hangs up until I pull the USB plug. It seems like the driver did not install properly. I tried installing it twice. I could try the USB ports on the rear that are used by the eLicense dongle, the mouse, and the keyboard.

1 Like

Just check you have the very latest ones from this link. It’s also worth making sure you have the latest BIOS for the Z270.

MrSoundman, I have been trying the latest Midex drivers, but have not checked the BIOS this year. But, your comment about the USB port sensitivity you experienced in the past led me to try an easy experiment. I found a 4-Port USB 2.0 hub and connected it between the PC’s USB 2 port and the Midex8 (and the Midex8 now using an external power supply). As soon as I did this, Windows asked me to restart Windows to finish the new installation. Upon rebooting, then running Cubase, all of my Midex8 ports are visible and active. I tried one with a MIDI synth keyboard used as a controller and it is now working nicely, playing HALion Sonic. So, after just a bit of additional effort, my Midex8 is working on my latest Windows 10 DAW-PC.

Thank you for the tips!
It’s time to create music again. :slightly_smiling_face:

… and thank you for that tip! I would never have thought of using a hub – it used to be frowned upon but the Midex is a USB 1.1 device so in this case, it’s probably woking like some sort of “compatibility layer”. Nice find!

It’s time to create music again. > :slightly_smiling_face:

Absolutely! :smiley:

1 Like

A lucky find!

FYI - my other USB devices on the Asus Z270 type mobo are:
Steinberg eLicenser dongle
Logitech wireless mouse dongle
Acer multitouch display control
Steinberg UR824

… and now, the 4-Port, USB 2.0 hub with the Steinberg Midex8 connected.

It appears that, originally, the Midex driver installation did not fully install in Windows 10 until the USB hub was introduced. During the first time the Midex was plugged into the USB jack, no installation wizard popped up as in the documentation. I don’t know if this normally happens in Windows 10. I just ran the latest driver .EXE file after connecting the Midex, and the system started acting weird. Windows hung up at a Black Screen during shutdown or restart until unplugging the Midex. Another weird behavior when the Midex was plugged in to the PC’s USB, Windows Remote Desktop Protocol stopped functioning. I frequently control this PC remotely from an iPad. These kind of problems can be challenging. Now Windows RDP works again, and Midex8 works.

1 Like