MIDI and VSTi Questions

Hey everyone -

I’ve been using Cubase/Nuendo for over 10 years, but in all that time, I’ve had little experience with VSTi and MIDI. The project I’m working on now is my first foray into them, and I’ve come across a few confusing and frustrating things that I’m hoping I’m just being dumb about.

Thing Number 1: Why can I hear a part I just recorded over?

This makes no sense to me - if I record a new part, it plays the old one back, too. And as far as I can tell, there’s only a way to automatically mute overlaps if you’re cycle recording, which I’m not. Now, I have a decade old workflow with audio only, so I assume I’ve overlooked an advantage to this process, but for right now, it seems rather clumsy. When the artist makes a mistake, I can’t just return to the location and start recording again - I have to pause, tell the artist to give me a minute to clean up, find a punch point, split the parts, and mute or delete the bad bit. Surely there’s a better way? Replace mode is better…ish. But then I can’t go see previous takes, the way I can with audio.

Thing Number 2: Instrument Track volume automation is being ignored

This one really feels like a bug to me - or I’ve done something foolish accidentally. I have an instrument track (not an instrument channel, mind you) with a VSTi on it (Organized Trio 3.1, if it matters). I put the track in write automation mode, and move the volume fader. The output volume changes as I move the fader. On playback, however, with the track in automation read mode (green R lit up) - nothing happens. The fader doesn’t move, the volume doesn’t change, the numbers indicating the current value for the automation do not change. Same when clicking to a new location. The volume and automation numbers stay wherever the mouse last moved the fader.

Also, it’s only the volume - not that I’ve exhaustively tried every single automation parameter. But the drawbar changes, rotator speed, etc, all work as expected.

One thing I’ve noticed here, the fader cap is slightly yellow, not white like the audio channels. I had assumed that this indicated the channel type, similar to FX channels having a purple fader cap, but perhaps this indicates that the automation value is being excluded somehow?

Update: Just restarted Cubase, and it’s still weird. But different weird. Now, I can hear the volume changes, but the fader and numeric value still don’t update.

Double Ewe Tee Eff?

Anyone encounter this? The plugin is an old, free VST 2, and it crashes VSTBridge every time the plugin unloads, so it’s dodgy - I’m not saying this is a Cubase problem. But it’s a problem for me :slight_smile:

Thanks
Tim

OK - Thing Number 2 might be me being stupid, sorta - I just rebooted, and now it works. I noticed that audio automation wasn’t updating visually, either, even though I could hear the differences. Then I remembered that I had applied the 7.5.10 update yesterday, and hadn’t rebooted. Since the reboot seems to have cleared it, at least for now, I think I just should have done that in the first place.

Anyway, the MIDI question still stands :slight_smile:

thing nr1 : you tried the track versions as a possible solution? (new in 7.5)
http://www.steinberg.net/en/products/cubase/whats_new/whats_new_in_cubase_75.html
you should be able to have as much different takes as you need without to stop the workflow.

thing nr2: are you automating the track volume on the mixer from a remote mixer or a controller ?
this automation of the mixer in cubase is seperate from the plugin and has its own automation on the mixer itself
if not and doing this on the plugin (f.e. with a mouse or a controller): controller cc007 should show something on the main window. if the plugin isn’t responding look in the preferences of the plugin and/or cubase itself since that looks like controllers are being filtered

kind regards,
r.

Do you want to simply mute the previous recording, or actually replace it (for which there is the “Replace” option, in the Transport Bar)?
Otherwise, as roel said, just click on the little arrow that appears when you hover over the track name, and create a New Version.