Midi Arp Sync on Cubase 8.1 Pro & Arturia MiniBrute

MiniBrute Arp & Cubase 8.1 (64-bit) Pro

I have sent MIDI out to the Minibrute and the arp syncs to the BPM of my project however (MIDI Clock Destinations -> MiniBrute checkbox checked), when I setup a MIDI track with a long note to fire the arp, most of the time the audio is a beat late! It occasionally starts on-beat as it should though.

It appears that although the arp is beat synced, the start is not in sync with the DAW. Please advise how I can resolve this.

Regards

Mark