Midi Auto Editing multiple events without wanting it to.

Thanks in advance. When I edit a midi event it is automatically putting the same edit in the next event that I had cut and paste before. I’ve solved this issue before, but I can’t for the life of me remember what setting I need to change. Thanks again.

Hi and welcome,

Ti looks like you are using shared-copy of the event (Can you see = icon on the right-top corner of the MIDI event?).

If this is the case, select the event, and use Edit > Functions > Convert to Real Copy.

There are those orange = signs on the folders too. Disable them

Do you mean Group editing?

This will not change other event, while editing. This will move the events together, etc.

OK Martin thank you , I confess I am cloudy on what group editing in folders does and does not do.


Thanks for the responses. It’s much appreciated. Basically I will make a midi event. Say drum snare hi hat and then I’ll
Copy and paste it through the verse then during the chorus I’ll want to change it up some but when I do it edits every
Part in the verse to look like what I just did in the chorus.

Are you sure, these are not shared copies?

Thank You, it was indeed a shared copy. Do you know how I made that happen…? I guess now i know what to look out for. Thanks so much for your help!!!


To make shared copy:

  • Hold down Alt + Shift while drag the event (Alt is for Copy, Shift is for Shared).