Midi Behaviour change in 11.0.20 - Ctrl mouse click does not allow note to vertically move

When moving a midi note with mouse I have always been in habit of holding down the Control key when selecting and moving. This is a known function to prevent moving the timing position of the note whilst being able to drag it to a new pitch.

Since 11.0.20 - holding down Control on the keyboard and selecting the midi note to be moved in Key editor causes the note to be locked from moving AT ALL.
However if you select the note without holding alt and fitst start to move it and then hold down Control on the keyboard it snaps to its original timing position - which is what you want.

Something changed with this in 11.0.20 and I believe this to be a bug. Perhaps those here can test this on systems and see if the same experience is had and confirm the change in MIDI editing behaviour.

Hi,

I cannot reproduce it here. It works as expected.

Could you try in the Cubase Safe Start Mode [Disable preferences], please?

I can confirm the behavior described by @mart .
But it doesn’t happen every time, not exactly reproducible :thinking:
Here Win10 1909, Cubase11pro

Hi,

There is another issue, I can see here on the forum (but I can’t reproduce neither), which is probably related… Sometimes when you try to copy the MIDI Note in the Key Editor (Alt + Drag and Drop), the MIDI Note is not copied. Can you also reproduce this, please?

Hi @Martin.Jirsak , this behavior I had already observed, albeit very rarely

Hi,

Thank you for the confirmation @P.A.T .

Hi Martin,

To reproduce can you try in MIDI key editor to:

Select a note with the mouse and do not release the mouse click.

Hold down Control now still with the mouseclick down on the note.

For me the note now refuses to move

If you key sequence it by holding Control down on the keyboard first and then going to move the note with the mouse it moves fine.

I tried Cubase wiith preferences disabled and checked. The same behaviour persists here.
i’m on Cubase 11.0.20 with Windows 10 build 19042

Can confirm that holding Control after selecting the note, the note does not move. If Control is pressed before selecting the note, it behaves as expected.

Platform:
Cubase Pro 11.0.20 Build 371
Windows 10 Pro 10.0.18363 Build 18363
64GB RAM

Thankyou for confirming. Perhaps we can get a few more to test this …

Confirmed in the key editor, but only in separate window, not if it’s in the lower zone.

STRG+click and hold+move: Doesn’t move.
Click and hold+STRG+move: Works as expected.

Hi,

Do you wait until the note becomes unselected? Isn’t it the Constrain Direction (Preferences > Editing > Tool Modifier > Drag & Drop > Constrain Direction) becomes enabled? Can you move the note at least in one direction?

That is the Function Martin - it is tied to the Quantize value I believe so you dont move a note’s timing when moving it’s pitch - but no the note will no move in any direction with that sequence of key presses. Prior to 11.0.20 this was not happening - I’m pretty sure - as its a keystroke I use a heck of a lot. I had been affected for weeks with it but have been trying to figure out why it was sometimes working… thats because I was using the keystroke order that does work… but very often I use the order that now does not (ie select note with mouse, with mouseclick down hold down Control and then drag the note vertically).

Hi,

I’m pretty sure of the opposite (sorry). I’m using this modifier very often too. And myself I wrote a feature-request to use other modifier for the Constrain Direction but Ctrl/Cmd, which is assigned to the Copy function, some years ago.

But now, something had to change in Cubase 11.0.20, if yours feeling is different. Maybe the timing…?

Hi Martin,

I’m only half following you here. You say you put in a feature request and you believe it has been implemented since what version.
My reason for using the phrase ‘pretty sure’ is that I can’t right not remember whether 11.0.10 had the issue but definitely the issue was not there in the inital 11.0.0.

Its more a bug in the order of whether you hold the note selection with left mouse click down first and then hold down control before attempting to move pitch vs. first holding Control down and then left click mouse down on note to move. One order works as expected (as it always has) and one locks the note from moving in any direction at all .