MIDI Bleed Between Channels - How to fix?

Here’s the scenario:

I have a midi controller, and it’s set to channel 16. It’s routed into a midi track in Cubase, and the track is set to channel 15. The track is receiving the midi signal and able to write.

This shouldn’t be happening. It happens with all of my midi controllers so I know that the problem is with Cubase. Neither the midi track nor the midi controllers have their channels set to omni.

How do I stop midi from bleeding across channels?


Nevermind. Got it figured out. Used the “Input Transformer” in the Inspector of each channel to pass the desired midi channels and filter out the others.

What a convoluted pain in the ass that was. haha


In the Preferences > MIDI > MIDI Filter, you can also filter all data of dedicated channel. :wink: