Midi CC Automation

Hi, I am new to cubase and cannot figure out how to record cc messages while recording midi. I have touchosc controlling cc1 and 11 with faders and they effect the sound of my instrument tracks, however when I record the data isn’t recorded. What do I need to do for this to work? Thanks.

To clarify, I am getting midi input but when I record only the notes are recorded and not cc1 or 11. How do I fix this?

Are you sure they’re not being recorded?
Everything should get recorded unless something’s filtered out, but if it’s affecting your MIDI track & resultant [VST] sound, which IS being recorded, then those CC’s should be as well.

First, click on one of your recorded MIDI tracks, and then open the List Editor.
[Top menus - File: Edit: Project: Audio: > MIDI. Default is ‘L’ on the keyboard.]

The list editor lists everything in/on the track. You should see them there if they’re recorded at all.

If you close that & open the Key Editor, you may not see anything until you add it at the bottom, such as ‘Velocity’, which is usually the default one that shows up there.

If you do see ‘Velocity’, hover your mouse at the right of ‘Velocity’, and a little black down arrow should appear with the pop-up, ‘Controller Selection And Functions’.

If you click on that arrow, a menu will open.

Click ‘Create Controller Lane’.

When you do, a duplicate lane will appear, ie: ‘Velocity’ again - [or which ever one was there that you clicked beside].

Click on that duplicated CC Controller’s black down arrow at the right again, and a bigger menu appears and anything that’s got some data recorded will have an *asterisk beside it.

Choose one of those for that lane & it will switch to it.

Then you can see & edit those values - ie: expression [CC 11] or modulation.

If still nothing, then you may have some CC messages filtered out in the Preferences, [File>Preferences] that need to be clicked [or un-clicked].

Ok, in the list editor it does have info about CC1 and CC11, however under the column “start” all of the cc events are the same number. The columns “end” and “length” are empty with no numbers in them.

In the key editor at the bottom where u can view the line graphs of specific cc messages, the ones for modulation and expression are just a straight horizontal line which is why I thought nothing was being recorded.

This is so strange because when I’m recording the faders on my iPad are working as they should and effecting the instrument track.

Any ideas of how to fix this problem?

Ok I tried using the mod wheel on an maudio keyboard and it worked. I now know that this is a problem that has to do with my iPad and touchosc. This setup has worked with other daws and should work fine in Cubase. I don’t get why it isn’t working but at least I know more about the problem now.

Problem solved!

http://www.vi-control.net/forum/viewtopic.php?p=3726060

For anyone else having a problem with touchosc and cubase, this thread answered my question and solved the problem I was having.

Hello!

I’m having the same problem!

What was the solution, the link you posted doesn’t exist no more!

I would start a new thread or at least state your question.

Record the output of something then open it in list view. You should see control messages in there if your device is putting them out.