Midi CC numbers ,I don't get it

I was having problems with Cubase 12 Pro crashing every time I used the sustain pedal on my Novation Impulse 61.

I did set up a midi Remote I was happy with but as soon as I used the Sustain pedal,Cubase crashed then I noticed the sustain was also MUTING ALL CHANNELS.

I then looked up on google midi CC numbers and found most of the CC numbers on the Impulse were already assigned to CC functions.

So I found the UNASSIGNED CC numbers and wrote them to a notepad file for reference.

I then changed all the Impulse buttons and faders to these unassigned numbers to avoid conflicts,the transport buttons on the Impulse were already assigned to unassigned CC Numbers so were fine.

OK ,all done,time to go into Midi remote in Cubase and change all the cc numbers to the new numbers.

But NOTHING WORKS,only the TRANSPORT oh and the SUSTAIN pedal works because it sits on CC number 64 which is not being used (at least that works).

OK I think,maybe I just need to remap them again.

So I remap the Impulse fader to volume channel 1 but when I do that,the APPLY MAPPING tab is GREYED OUT.

I think I’m going Bald.

P.S. These are the CC numbers that are unassigned that I used for the Novation Impulse 61.
MIDI CC 14-15
MIDI CC 20-31
MIDI CC 85-90
MIDI CC 102-119 TRANSPORT (112-117) 102-111
The TRANSPORT cc numbers work fine.
Everything else does not respond.

What is a great MIDI KB for CUBASE? ,something that does not splutter and cry like the Novation Impulse does?

Maybe the Impulse does not like it’s default CC numbers being changed and cracks a hissy fit?

The trouble is those CC numbers are already used and assigned like pedal sustain etc…

Is there a KB that does not crap itself with MIDI remote and uses the proper unassigned CC numbers?

I decided to upgrade back to 12.0.51 from 12.0.50.

When using the corresponding knob on the Impulse for QR,an Error message comes up in Cubase and I have to close it.

I bet you if i go into REAPER and assign any Impulse button,none of these errors happen.

Ok I did these actions in REAPER.
Everything worked what I threw at it.

I finally worked it out in Cubase but STILL some actions refuse to work and I know the CC number is working because in the Cubase Button Properties/ Value/Message/Control Change there is a little icon MIDI MONITOR which I use to see if the Impulse buttons I use register a response WHICH THEY DO! BUT I can’t assign functions to those particular buttons and the buttons DO NOT Register anything through MIDI REmote mapping.

The Cubase actions I am struggling with are Select Next track and Select Previous Track.
Also I CAN NOT select my different MIDI Remote maps,Default or Mixer so my Impulse rotary knobs can switch from pans to QR controls.

I get this message when pressing the 9/Master button on my Impulse(the square icon to the right on the row below the faders.

This is a major bug in the Cubase software and hopefully a quick fix comes soon.

Another question ,do DAWS conflict with each other as far as midi mapping to confuse one over the other?

Please rollback to Cubase 12.0.50. We will deliver a hotfix for the 12.0.51 crash issue within few days.