MIDI CC Track Automation is broken

Edit: The issue is not Retrologue related. Retrologue was chosen for testing purposes because most Cubase users have access to it. Any VST or external instrument can be use for tests as this is a general midi issue.

Steps to reproduce:
1/ Using a sine tool with 16th quantization value automate Retrologue’s filter cutoff VST parameter in the arranger window - sounds right, smooth and regular
2/ Cut the automation from the filter automation lane and paste it to MIDI CC 74 (Brightness) automation lane in the arranger window - this time Retrologue’s filter cutoff will be automated using MIDI CC automation - sounds off, not smooth and irregular

You can start with drawing MIDI CC automation and moving it to filter cutoff parameter automation - result is the same - vst parameter automation is smooth, MIDI CC Automation isn’t.

Drawing sine automation using 16th quantize value and 1/128 length quantize value in the MIDI EVENT, however, gives a smooth result. It is only MIDI CC automation in the arranger window that is broken.

Hi,

Is it on the Cubase side, or the plug-in side? Can you reproduce it with other parameter, other plug-in? If you add MIDI Insert MIDI Monitor to the track, can you see sending MIDI data? Is it OK?

It’s definitively on the Cubase side. Sorry, I should have probably been clearer on that. I chose Retrologue because most Cubase users have it. This issue is midi related, not plugin related, as it occurs when any VST instrument or even external midi instrument is used with any parameter automated.

Using LoopMIDI drivers, I recorded the output of the automated midi track (SOURCE) to another midi track (TARGET) and extracted the recorded midi automation, so it could be seen in the track automation lane for comparison. When the automation is auditioned using Retrologue, automation from both tracks sound quite the same and off.

Hi,

I just tested MIDI Data out, MIDI loopback, record back to the 2nd MIDI track. I even didn’t quantize the Sine, when I created it. The result seems to be totally OK to me (see attached screenshot). As you can see, the Zoom level is pretty big.

The 2nd screenshot is, when I sent out the data as a real automation (not the MIDI Track CCs), and write it back as an automation. The Automation Reduction level was set to 0. It’s not perfect, but it’s still pretty OK. Are you sure, you didn’t make a MIDI feedback?


I also have the Automation Reduction level set to 0. No feedback was introduced, as LoopMIDI disables its virtual ports when feedback is detected.

TBH first screenshot doesn’t look good to me. Did you audition this automation and compared it with VST parameter automation?

Automation on second screenshot looks as expected, because there’s no problem with midi automation inside midi parts.

I’m sorry, the screenshots are in the opposite order.

Yes, the 1st s reenshot is NOT OK. This is an automation > automation. And this is the issue, you described, right? The 2nd screenshot is OK, which is MIDI CC > MIDI CC.

That is correct.

I will try in an older Cubase versions and then report it as a bug.

Thank you! I believe SX3 is the last version that works correctly. I have conducted some tests in the past, but didn’t have time to document this.

BTW I remembered there is a preference setting which allows to record midi automation as track automation, but couldn’t find it, thus I was using “extract midi automation” method.

I finally found this setting: MIDI menu>CC Automation Setup> “Record Destination on conflict (global)” option to “Automation Track” instead of “MIDI Part”.

Credit goes to user vic_france https://www.steinberg.de/forums/viewtopic.php?p=560468&sid=7ce4cc6adeff77f7591434500f1fefa8#p560468

One more screen-shot showing that midi out data is being significantly reduced on output when midi track automation is used, despite having Automation Reduction level set to 0.

I’m not with Cubase right now. Can you send it as an Automation, and Record as MIDI data, please? Is it also reduced in this case?

Recording to midi part also reduces the data, strangely it turns out that the reduction is conducted differently - the resulting shape of the automation differs from the automation recorded as track automation, sounds differently too - more regular, though the shape is more squarish. Still off.

Here is an audio example:

1st part - MIDI CC automation recorded as track automation (as described above) - erratic
2nd part - MIDI CC automation recorded to midi part (as described above) - erratic, sounds different than in 1st part (better… sort of)
3rd part - VST Parameter automation drawn directly within the track (correct one, regular)

https://1drv.ms/u/s!AtbbTGcZOEa1hLYwIbbbBg8MR0_yxg

Martin, have you managed to report this bug? I don’t see it in “issues” section. Or did you report it directly to Steinberg?

Yes, I reported it directly to Steinberg.

Yes, I reported it directly to Steinberg.

I’m glad to hear this! Thank you! :slight_smile: