Midi CCs not coming through to AUv3

  1. Summary/Title
    CC numbers assigned from Korg NKS to match with GSi BE-02 delay effect numbers, working in standalone but not hosted in C3.
  2. Description
    See above
  3. Expected Result
    Have the knobs moving in the plugin for live playing/tweaking and automation recording.
  4. Actual Results
    Only works in standalone, indicating C3 is the culprit.
  5. Environment
    All updated ipad gen 8.

Thanks in advance guys!

Hi @ehehehe,

Thanks for your message.

Normally, there should be no issues to use MIDI CC with 3rd party AU apps (as long as the apps itself support this).

Please check back with the app vendor. If required, I’m at hand to have them equipped with a Cubasis promo code for testing purposes.

Hope that helps!

Stay safe,

Since ‘stand alone app’ and ‘AUv3’ are separate instances there might be a need to remap the CCs in the AUv3 Plug-In if it has any CC mapping capabilities?
(AUM again handles this easily with integrated CC → AUParameter mapping capabilities).

Also In Cubasis in order forward all CCs to a plug-in the track apparently needs to be armed for recording otherwise it will not fully process the midi input?! (This feels a bit weird to be honest).

If the AUv3 Plug-In is hosted on an Audio Track in Cubasis there is currently no way to directly forward Midi Input to the AUv3 Plug-Ins which is easy to do in other hosts like AUM.

In Cubasis plug-in automation recording can also be done from the Plug-In UI (Enable W and tweak the plug-in during playback) which is also the only way to automate plug-ins hosted on Audio Tracks.

Does the AUv3 respond to Midi CC’s when used with other AU hosts?

I do not own the AUv3 Plug-In in question so it might be worth to get in touch with the plug-in developer.

Hopefully this will be sorted out but there’s too many ‘loose ends’ to tie up in troubleshooting this.

I have sent them a message linking to this thread. Thanks for your reply!

Thanks @ehehehe!
Guido is already equipped with a promo code for testing…


Great, thanks!

Problem solved, user error!