MIDI channel input configuration

Hi everyone, Im having a problem sending MIDI from mpc one to cubase pro 10.0.6, i want to send midi to different instrument channels but its playing the same in all of them.
Ive tried in ableton and works perfectly, each vsti receiving in its own channel and very simple routing.
Am i missing something?

On the the Track’s Inspector change the Channel setting to “Any” instead of a specific Channel Number. If you set it to a specific Channel it will convert each Note’s Channel Number to the value set in the Inspector. Setting it to “Any” leaves the Note’s Channel Number unchanged.

Thanks for answer. I tried to set the tracks to any, but how cubase will know wich track is going to receive data (midi channel in).
im using mpc one as a sequencer, so i make automations and patterns in the mpc midi tracks to send to different vsti plug ins in instrument tracks in cubase.

Yeah, that is a common misconception that the Track’s Channel Setting controls what Channel the Track is listening to. Actually it only controls the playback. If you record your multi-channel MIDI data to a Track set to Channel 1 and then open it in the Key Editor you’ll find the Notes for all the Channels. And all of those will retain their original Channel number. If you then play it back they will all play on Channel 1, unless you change it to “Any.”

The way this is setup isn’t very intuitive, but ends up being pretty flexible once you sort it out.

To have a Track only listen to specific Channel you’d use the Input Filter.

1 Like

thanks for help and tip, i was able to do it with the midi input filter

this little tutorial was very helpful also: