Midi Channel Nightmare

Hi,
Im running an instance of Kontakt as a VST Instrument rack hosting multiple instances of a library, each set to a different midi channel.
I have set up midi tracks all sending to Kontakt on different channels, for different instruments. This works.
My simple goal is to switch midi channels on my midi keyboard and be able to play the individual instruments.
With all tracks monitored or record enabled for some reason one midi channel fires all instances in Kontakt, as show in the picture below.
To confirm, when the screenshot was taken, my midi controller was set to transmit on ch2 only.

I’ve been able to get this working without issue in Ableton Live, but not in Cubase.
Any suggestions as to what I maybe doing wrong?
Thanks

Link to image as I cant post a full size screen shot:
https://i.imgur.com/6kLMoja.jpg

Then certainly the output routing MIDI channel setting in cubase is not correct.

You’d think, but look at the routing on the right of the image. All tracks set to Kontakt-In with the corresponding Midi Channels below 1-5, which you can see assigned to the instruments in Kontakt.
Midi Monitor on Track 4 (Cello) assigned to Midi Ch4, shows CH4 transmitting but yet all instruments respond in Kontakt.
Must be doing something wrong somewhere.

No it´s like I said - All output channels must be set to “Any”.

For troubleshooting, have you tried to see if this happens in Kontakt when run in standalone? That would at least tell you if the routing issue is from Kontakt or your controller set-up or if it’s in Cubase. I ran into this a while back and it was in Kontakt, but it’s been long enough that I can’t remember how I resolved it.

You are welcome.

Sorry, I’ve been busy with work etc so not able to check here too regularly.
The ‘Any’ fix worked - to an extent, so indeed thanks! Although I can do as intended, play different instruments inside Kontakt from differnt channels on my midi keyboard, this does then cause an issue when I playback recorded midi as all midi tracks then transmit to all channels.
I am confused as to why a midi track can’t be set to broadcast on a specific midi channel to a VSTi…
Yes, I should probably ‘RTFM’.