Midi Chorder Display bug in latest 9.5.30 release?

I’ve just noticed that the Midi Chorder Insert seems to have a bug. Can anyone else please confirm this?

When I play the notes, the display should show vertical lines to indicate the notes triggered [pic A] but when I play notes, the display doesn’t update which means I can’t see which notes in the chord are being played back. [pic B]

I don’t recall this being an issue in v9.5.0 so is this a bug that’s been introduced in 9.5.30?

Hope this makes sense… I’m not sure if it’s an error in my system or the program.

Thanks in advance for any input on this.


PIC B.PNG

Hi,

What chord is displayed then? Just the very first one you played?

Sometimes…

I’ve used it many times in the past and with each key press, the display would show all the notes assigned to the chord in real time [as those long vertical lines]

However now with each press, I might see a chord displayed once every 5 or 6 keys played and sometimes not at all. I know somethings not right because if I mouse over the display, vertical lines (notes) start to show.

Are you getting this sort of behaviour on your end or if you play several chords, does the display show all the notes as vertical lines in real time?

Thanks

Sorry, I can’t check it right now on my side.

Could you add some basic specification of your system to the signature, please? Mainly your Windows/OS version, that would help.

Just added my system info.

It’s just frustrating because I reinstalled 9.5 and it worked fine. I then installed the 9.5.3 update and now I get the problem.

Just need to know if it’s an issue on my end or a bug with the update.

Thanks for your input, I appreciate it.

Hi,

Could you try in Cubase Safe Start Mode, to know if it’s reproducible with the fresh preferences, please?

I’ve not used the Chorder before, but I checked it out because of this thread. What I found is that after assigning chords to keys, playing those single finger keys:

  1. ALWAYS updates the alphanumeric chord name displayed in the GUI correctly (and output is played correctly).
  2. DOES NOT update the graphical piano key display (the colored long vertical lines) UNLESS the single key press falls in a different “velocity bin” than the previous single key pressed. The output chord played is correct, though.

In other words, with my three velocity layers I have assigned, if I press several different single keys within the lowest velocity bin, the key graphic will not change between different chords (single key presses). If each sequential single key press is with a different velocity bin (e.g. Alternating between very soft presses and hard presses), then the graphic updates the graphic display every time.

I don’t know if this behavior is normal as I’ve not used this feature before. Nor do I know if it relates to the OP’s issue, but perhaps it’s related in some way.

Pete

I tried booting in Safe Mode but the eLicense dongle failed to be recognised even though it’s connected directly to the laptop which means Cubase wouldn’t start without activation. I noticed the red light going out [on the dongle] shortly after being connected [I’m assuming safe mode reduces power to the USB ports or cuts it off all together]

I’ve also tried trashing the preferences by deleting the contents in the ApData/Roaming/Steinberg 9.5 folder. No luck.

Thanks for trying this out. To simplify, I’ve removed the layers function [Layers> single mode] so that on any key press, the associated chord plays & [should] display the notes [vertical lines] regardless of velocity etc.

I’m not getting the chord read outs at the top but I am [as you said] hearing the correct chords being played back. Also, as mentioned at the start, I rolled back to version 9.0 and the issue didn’t exist.

If you play in single mode, are you seeing the chords being played back in real time [as the vertical lines]?

Thanks again.

Hi,

I was writing about Cubase Sade Start Mode, not Windows Safe Mode, please.

Oh, this is actually new to me, was unaware this mode even existed. I disabled the preferences option but with no luck :frowning:

I tried to attach two very short video clips to further display this issue but was unable to as this forum doesn’t allow posting video files as attachments :frowning:

Hi,

Could you place the video somewhere and send the link, please?

https://www.dropbox.com/sh/k7f74au3gsv1tdt/AABi-RXta4kOJiJyIbjxfZSpa?dl=0

Let me know if there any issues with the upload, I haven’t used dropbox in a while.

Btw the video with the problem isn’t supposed to have sound.

Hi,

I’m not sure, if you understand the concept of Chorder completely. Please read more about it in the manual, here.

Please elaborate. I don’t feel there’s much to understand unless I’m mistaken?

Chords can be assigned to keys either per key, per octave or globally. They can be assigned to layers or without. Regardless of all the above, the display should show which notes are assigned to each key upon note on. This is the behaviour I had when using version 9 [and prior] that has all of a sudden changed to a more non responsive gui when playing with the latest 9.5 update.

As the videos show, when I play the chords now, I have no idea which notes are playing back. Also, as pointed out, the second video isn’t supposed to have audio as I recorded the video via Windows 10 game bar (for the first time) and didn’t know how to configure recording a screen cap to include audio. [The first video where it works as expected was grabbed from a tutorial on youtube] I hope this isn’t why you feel I don’t understand how it works?

Btw I’ve read the manual and it hasn’t helped in any way with the issue unless there is a particular passage that I seem to have missed relating to the problem?

Regards

Hey 40W,

Been away a while, but I did just test as you specified, and am getting the same thing you are. In single mode, as soon as left learn mode and started playing the single finger chords, the middle display (the one with the colored vertical lines) changed to display two notes (not related to any of the 8 chords I entered) and stayed there, not changing when different single finger chords were played.

I think there is something bizarre going on because (get this!) I went back to Cubase in the middle of writing the above paragraph, and noticed that different notes (colored vertical lines) than the two that were being displayed than when I left Cubase to write this. And … I just noticed while playing a new and different single finger chord does NOT change the colored vertical lines displayed, if you hover the mouse over colored vertical line display, and move the mouse across the display, the colored lines DO update to the last chord played, one note at a time as the mouse cursor passes over the new notes that should have been displayed.

Try that and see if you get the same thing: set up a one octave single layer set of chords, play (I used MIDI controller) and watch the colored vertical line display remain static, then move the mouse up to that display, drag across the whole display and see if the vertical lines then change, and display the last single finger chord you played. If that happens to you (& me!), but not everyone, perhaps there is an issue, possibly system related … like perhaps if I were to guess … video drivers? Maybe this will provide some more clues for Martin.

Pete

Thanks Pete for verifying this. And yes, I was actually aware of this with the mouse cursor and should have mentioned it earlier. If you wave the cursor across the display the notes change. This was another key reason that led me to believe this is some sort of bug with the gui after the 9.5 update.

Thanks again for highlighting it.

Just received a reply from Steinberg Support about the issue and they confirmed it’s a bug. The response is below:

"unfortunately, due to maintenance work on our servers, the processing of incoming emails has been delayed. I’m sorry that your inquiry could not be answered within an acceptable period. Please excuse the inconvenience!

Thank you for your message and all the information, I would just inform you an official Bug report was already opened about the MIDI Chorder Display issue. I hope Steinberg developers team I will be able to solve this issue as soon as possible."

Hopefully it will be fixed in a not-too-distant update!

CAN-18585