MIDI clock output issue

Hi guys, here’s a little thing that I have been working around. I have been using Laurent Colson’s Steppolyarp app for a while now, but from the beginning it would never sync with Cubasis MIDI clock out. It would sync to other apps like Little Midi Machine etc with no problems. To make Steppolyarp work with Cubasis, I launch both apps first, and then launch Audeonic’s MidiBridge app. This seems to “fix” the MIDI clock and Steppolyarp then follows Cubasis perfectly. Although this works for Steppolyarp, it has side effects with other apps such as Yonac’s Magellan synth, which seems to see two versions of the clock signal from Cubasis and MidiBridge, and it runs at double tempo. I realise this is nobody’s fault but probably mine for using this particular combination of apps, but it is annoying at times! Anyway I asked Laurent Colson about this and he said it was due to a “non standard” clock signal from Cubasis. I didn’t give this much thought but then realised that Little Midi Machine would not sync using the Cubasis clock signal, but would only sync using the Network session clock signal - which is of course being generated by Cubasis in the first place. So, I have two apps which cannot recognise Cubasis clock signal directly, but will sync to each other and various other apps without trouble. I know it’s strange but do you have any thoughts about the “non standard clock signal” comment? Anyway hope that my experiences will help towards refining Cubasis - it is my number one musical tool!
Keep up the good work and best wishes :slight_smile:

Hi microtoneaudio,

We have sent Laurent Colson a note to discuss the issue.




Love to know what the result of this inquiry is.

MIDI clock is a real bug bear … There’s no good way to tell where problems are… Is it the sender or receiver? Cubasis has side stepped by only generating clock… I suspect syncing to a clock is much harder! But it’s good to see SB reach out and help fix problems…

I really hope some dev can standardize a way of routing MIDI really well in iOS… SB?


we let you know asap… :sunglasses:


Hi, I’m experiencing similar problems with midi clock output. Since 1.8 update my slaved DSI Tempest is going out of tempo after one or two cycles of a pattern. It’s just happening in “loop mode”. I know the problem is on cubasis cause it’s not happening with another ios sequencers wichs sends midi clock out. Any solution or suggestion?

Thanks in advance!

PD: I’m on Ipad Mini Retina using Iconnectmidi4+

Same thing happens with Sector. Apparently it’s a known issue in Cubasis. In Sector you can turn off “follow host” after you’ve started so it no longer receives the bad signal. Less than ideal, but it works until Cubasis fixes their midi clock send.

Hi Rerun, thanks! … It’s strange, it used to work ok on 1.7 and ios7

Hey SB… Laurent never responded to your note?