Midi Clock sync with beatstep

When using MIDI clock to try and sync arturia beatstep the time drifts out over a short period if using looped playback. Playback start/stop works ok, just that the pattern gets out of sync, it is like the beatstep gets ahead of cubasis.

Is this a problem with midiclock send from cubasis or midi clock receive from beatstep ?

I am using iOS 8 on ipad mini 2, latest version of cubasis, and latest Beatstep firmware.

I get the same problem using Steppolyarp. The developer, Laurent Colson, says it is because Cubasis seems to insert an extra clock sync signal upon repeating a looped section. Annoying, but if I really need to work with looped sections in Cubasis I manage to get around it by using MidiBridge app, which apparently creates its own “clean” midi clock signal. It’s pseudo-sync because it isn’t really slaved to Cubasis clock - but it seems to start and stop and follow song position reliably, and in practice I can’t detect any drifting away from the Cubasis metronome after repeated looping. A weird side effect is that it makes Yonac’s Magellan synth run at double tempo. I don’t know if other apps with MIDI clock sync are affected in any way. In short: Cubasis would seem to be the culprit. At least Steinberg are aware that WE are aware of it :slight_smile:

Thanks for the info microtoneaudio, I have midibridge so will give it a try. For midi bridge setup do you just create a connection between cubasis out and beatstep in ? Or do I need to do anything 'clever :ugeek: ’ in midibridge

When syncing Steppolyarp to Cubasis, all I need to do is launch Cubasis and Steppolyarp first, and then launch MidiBridge. I don’t need to create any connections - it looks like MB automatically recognises Cubasis and Steppolyarp as CoreMIDI objects, and everything just syncs. Don’t know if this method will work with Beatstep, but give it a go and let me know. As I mentioned previously, if MB is active (or even after I close it) I get a weird doubling of tempo with Magellan’s built in arpeggiator and LFOs. But hey that’s all part of the fun with iOS music making…

MidiBridge has not helped with the BeatStep unfortunately :frowning:

Any chance the dev’s here could talk to Arturia dev’s to get a solution ? From both forums both set’s of dev’s seem keen to get issues like this resolved :slight_smile: If it helps I have a case raised with Arturia Case No.194972

Hi All,

I did some tests with cubasis as midi clock master and iElectribe drum machine as midi clock slave.
All works as expected, start, stop, cursor positioning and playback in cycle.

It’s in sync, no drifts in 4 bar loops after 20 cycle playbacks.

same results with external hardware devices like “Korg Electribe SX” and “Motif ES8” as midi clock slave.

How long is your cycle ?
After how many cycle rounding the drift is coming ?

If it’s possible please check with the iElectribe drum machine.

best jan

Hi Jan

I get the drift immediately after loop returns to start for 1st time, and the drift increases with each iteration of the loop. I have tried with 1, 2 and 4 bar loops, all react the same, and this happens with both iElectribe and Beatstep. If I do not loop the sync is fine.

It’s encouraging to know that you have it working fine though. Anything I can check for you, version numbers, latency settings etc…

Hi AndyPlankton,

<and the drift increases with each iteration of the loop.


I can’t confirme drift increases with each iteration with iElectribe and external Electribe SX,
ipad Air 1, iOS 8.1.2.

I triggered 1/4 closed hihat right side Am Pob kit 1, left side iElectribe only closed hihat.
Midi output latency - 7, all is in sync, no drifts. If i change the tempo 160 bpm - 50 bpm and back, during the playback for several times, the iElectribe follow them in sync, no drifts, also in sync after 10 minutes iteration of the loop.

Please close all apps, restart iPAD + cubasis and iElectribe and check again.

I did intensive Tests since we implemented Midi Clock. There is something different between our setup.

best jan

Hi Jan

I exited running apps. I turned on Airplane mode, Powered off iPad. Powered iPad on, and have nothing connected to the lightning connector, I started Cubasis and then started iElectribe
1 bar loop with 1/4 notes on each, drift starts immediately the second pass of the loop starts and gets progressively worse with each iteration of the loop. The iElectribe gets ahead of Cubasis, reaching a difference of 1/16 note in about 6-7 iterations of the loop.

Like you say there must be something different between our setup, but do not know what ?

I have iPad mini 2 16GB wifi Only and iOS 8.1.3 (problem happened in iOS 8.1.2 also). Cubasis is v1.8.3 and iElectribe is v1.6.3

I have midi output latency set to 0, and audio hardware latency set to 256, Background audio is set to on in both iElectribe and cubasis

Hi All,

Andy post me his test project, wich has my settings, I used in my midi clock tests.

I must say:

I can confirmed midi clock sync drifts, after each cycle iteration, since I import his test project.

It’s easy to reproduce and audible. I don’t know why we never can’t reproduce it before, with the same settings.

So we can say, after each cycle iteration, it’s drifting faster, how smaller the cylce is.

Sorry for the circumstance to all, they will use midi clock in cycle settings.

Same results in the next current cubasis version :blush: , we will investigate and inform you, if we have an solution.

thanks to AndyPlankton to be patience in this issue.

best jan

Hi, i’m having same issues with a dsi Tempest.
It’s strange an maybe it doesn’t have sense but… I’m sure I didn’t had this problems in ios 7 and cubasis 1.7 . maybe it can help. Thanks!

I’ve also had similar issues ever since I’ve owned Cubasis about 7 months ago. My loops will occasionally drift too, but my main issue is that Cubasis will double the clock signal (as mentioned in the second post above) to all of my hardware gear, which includes:

  1. Beaststep
  2. teenage engineering OP-1
  3. Korgs electribe 2
  4. Korg Vocla Keys and Beats
  5. Nord Drum
    And list goes on…

I will say that, I do have a fairly complex setup - with a iPad Air, Focusrite iTrack dock, and followed by the original iConnectmidi. Haha, I know I have a headache too.

For the most part, my solution is to plug Amy of my hardware pieces directly to the ITrack dock’s USB port. Cubais will still double my tempo, but oddly enough, even though my piece of gear reads double the tempo, it plays back into Cubasis at my desired tempo.

Hope this makes some sense

bump -Anyone find a solution at this point?

Unfortunately not, still waiting :cry:

Oh man, that’s bummer - for this reason I had to sell off my Beatstep earlier this year, but my Beatstep Pro will be arriving to me this week and I imagine to have less issues since the BS Pro has 5 Pin MIDI in and Clock in. But knowing Cubasis’ temperament while working with others - I’ll probably end up with more options which means… more syncing issues.


I’m not sure that the timing issues aren’t in iOS itself and not within the control of the developers. With so many apps having issues with Sync it seems logical. :cry:

If Steinberg can add ghost parts to Cubasis (requested in another thread) this would offer a workaround as we could simply make many ghost copies of our midi loops meaning we wouldn’t have to use cycle playback on a small loop. It’s not a perfect solution but would ease the situation as we would only have to make the copies of the parts once and not every time we make a change. :unamused:

I’m not jealous of you and your BS Pro at all. Honest :mrgreen:

So Beatstep pro works with Cubasis when it syncs up with Live 9. Albeit, I have quite a powerful iOS midi system now with iConnectAudio4+ and the BSPro just adds more connection magic that I can’t complain about.

Ghost parts sound interesting.

One year later, and clock sync still a problem, my Teenage Engineering OP1 is drifting when clocked to Cubasis loop… are there any workarounds? I don’t get this problem with Auria Pro