Midi connection help, please?

I have the C7 trial loaded on my PC and cannot connect to my midi keyboard. I must be doing something wrong but then again, I have C6.5 up and running and have everything set the same way and everything works. Is there some trick here? Thanks you in advance!

well if you have all the right boxes tick , which i should think you have , someone mentioned a fix on here of opening up something like midi ox before cubase and that activated the midi in cubase ? have you ticked the midi throu box in the preferences first ?

Hey, yes, I do have that box ticked. In the transporter ‘midi out activity’ the blue output bar lights up as I touch a key so something is happening. I just dont have connection to the VST instruments. Man, I must be stupid! :laughing:

MIDI filters…!?
Or what is happening when exactly…?

Well, like I said, if i hit a key then the bar light on the transporter that indicates ‘midi out’ (not both indicators, just the one) will light up. If i create a midi track, the output is not seen in the channel indictor, so this is the issue. Consequently Halion, LoopMash, Pad Shop, etc., cannot be controlled by the keyboard. They can be controlled by the on screen keyboard, of course, so I do have a working VST instrument.

https://www.steinberg.net/forum/viewtopic.php?f=181&t=36354

And you are sure, it´s the MIDI out? And the “key” is a MIDI keyboard or t a key on the piano roll…?I

Wow filterfreak that is me. The problem is I have no stand alone midi programs. Hm. And just like the one poster, I can run C6.5 without a hitch. This is odd behavior.

I remember there was that midiport enabler file in Cubase’s system files, remember? I just can’t imagine an updated version of Cubase would be doing this. Well, there’s yet another reason to slow my purchase of C7. Thanks for the heads up!

OK, still dealing with this. There is something different in the midi output meter on the transporter in either Cubase version. One is red (C6.5), the other blue (C7). Eh?

I did find a post in the ‘solved’ C7 issues folder on the forum. Here someone named Alex was having the same problems. Eventually Steinberg posted a solution that DID NOT WORK (for a myself and another poster) and then everybody dropped of the post. Weird. Helge came back and asked if Alex solved his own problem and there was no response… It’s a jungle out there.

Does anybody else have any ideas?

Screenshot of the Inspector of the MIDI track?

Immortal, thanks for responding. And to the others, as well, thank you!

It is working now after I closed C7 down and reopened it. I didn’t make any changes but instead loaded every midi controlled VST in the program, trying them all with no joy. I also had my C6.5 up and running, comparing it’s settings. both were identical. And, yes, C6.5 was working fine.

Now I did do one thing that was suggested in another post, the one that Alex was involved with that I mentioned. Here Steinberg suggested deleting a file:’ Midi Devices.bin’. I found this in ‘…appdata\roaming\Steinberg\Cubase7_64.’ So, this may have been the fix afterall. ?? I will assume it was. If not then I will write it off to a new install and the software making some unannounced adjustments.