MIDI Control AmpliTube

I’ve been trying to control AmpliTube 4 as a VST inside Cubase Artist 10.5 with an external controller and can’t get it to work.
I’ve got a Line 6 FBV Mkii Express and it works fine running AmpliTube stand-alone - as does turning pedals off and on, doing program changes, etc.

Cubase sees the controller input but it doesn’t seem to get to AmpliTube. There are ‘learn’ buttons in amplitube that wait for input but never get any. Maybe AmpliTube doesn’t support VST to that extent? I’ve asked about this in an IK Multimedia forum as well.

I this controller specifically so I could start/stop recording in Cubase using the foot switches while using the expression pedal to control AmpliTube volume/wah/etc.- therefore never having to take my hands off the guitar. That would be so cool.

I can control Cubase record/anything with the Line6 so that much works at least. Just for fun I created a midi track with the line6 as input and output to the audio/amplitube track but still nothing- which was no surprise but hey got to do something with all this quarantine time!

Has anyone been able to control Amplitube in Cubase like this?

I really hope you get an answer for this soon HoltDan as I’m having the same issue with Amplitube 4 myself. I’ve reached out to IK Multimedia/Steinberg but have had no luck with any kind of response yet…frustrating, especially in these times of isolation!

I don’t have much hope at this point. I also posted over at IK https://cgi.ikmultimedia.com/ikforum/viewtopic.php?f=5&t=22521&p=100645#p100645

There’s a response there about getting in touch with IK tech support which I haven’t done yet. I wanted to poke at it a bit more but this sort of troubleshooting sucks the will out of me pretty quickly. Especially when you’re dealing with multiple vendors. Pretty sure it’s not the Line 6 controller - I could monitor the MIDI data Cubase is receiving and it’s correct. Even weirder is that when I move the expression pedal Cubase starts playing. More movement does nothing.

I also tried using the VST Amp that ships with Cubase and put a wah in it. The pedal still did nothing which was no surprise since there was no indication inside that plugin that it’s midi-aware at all. Don’t know if that’s a clue or not!

Fortunately, I’ve been more in the mood to just play/practice than record. Not that this is preventing me from recording - and does the world really need another wah-drenched, overwrought pentatonic guitar solo in these trying times? What am I saying? Of course it does! Help!

The YouTube godz smiled upon me and sent this recommendation: https://youtu.be/kOR9ILsy-pg

I tried creating a MIDI track when I was 1st trying to figure this out but must have had the routing wrong.
I haven’t played around with it much yet but it works now! You record on both the midi track and audio track simultaneously. I hadn’t thought about it in terms of recording the midi separately (thought it would record the wah-ed audio) but this certainly makes more sense.

Hope this helps

That’s great HoltDan! The only problem I’m having now is my Amplitube does not show up in the midi track itself, even though it shows up in the audio track. I received a reply recently from IKMM but they could not help as they feel it’s a Cubase issue. Will keep you posted as I get closer to solving this issue! Cheers!

I have the same issue, could you get it work?

I have the same issue: can´t send program change from Line FBV to Cubase, did you get it to work?

Had the same Problem and solved it.

  1. Use VST 2 instead of VST 3.
    In my Case the Midi PC Signals for changing Presets were failing in the VST 3 Version. It works flawlessly in VST2!

  2. If not only the Midi PC, but also the Midi CC are not working its probably a Midi Routing Problem. (Check with the Midi Map Feature in Amplitube)

In this Case check the Midi Routing (there are some youtube Videos). Basically use an extra Midi Track and Midi Send it to Amplitube.

Hello!
How can you choose between VST2 and VST3 preset?
If I load the amplitube preset, I have only one option.

Thanks!