midi control nightmare! please help :(


I really want to remove all midi controls for vst instruments that i load up, so that i can set them if and when i need them. I’ve gone into the generic remote in device set up and deleted all controls but when i select a midi track linked to one of my vst’s, the faders on my controller still have functionality. volume, vibrato etc i really want to turn this off but can’t figure out how.

Kindest regards and thanks in advance :slight_smile:


This sounds like VST and/or Track Quick Controls, which are also located in Device Setup. You should be able to simply set them to “Not Connected” and they won’t bother you.

hey steve,

cheers for your reply. i have tried turning off quick controls and disconnecting my controller in device setup but faders still seem to be controlling the volume on the instrument :confused:

Since you haven’t given details about your setup, that’s all I can offer.


cubase 7
m audio oxygen 49
focusrite forte soundcard
ni komplete 9

I had a problem a while back where some controls in my VSTi’s were by default (presumably decided by the manufacturer) set to receive CCs that Cubase was chasing (midi chasing). This cause sounds to change as I relocated the play cursor around the song! The only way I could find to disable this was to set the control to receive a different CC number which I knew wasn’t going to be sent at all. I did this IIRC by editing the preferences of the VSTi. However, there wasn’t a way to turn it off, or to change the default that I found :frowning:

Going at it the other way you could place a transformer on the midi input and change the CCs to other numbers which aren’t commonly used, then selectively change the VSTi’s or the input filtering. Or filter them out entirely…


ah! nice one mike :slight_smile: sorted.

Many thanks