Midi Controller Not Sending Notes

Hi, I’ve recently got a new rig (Windows 11) and I’m having intermittent issues with Cubase 11 not detecting notes/data from my midi controller. The controller is a Hydrasynth so no drivers per-se, but its fully updated and is showing as a device in Cubase and for the most part, other than this happening intermittently, works perfectly.

The controller is showing as active for MIDI-in in Studio Set-up>midi ports, but inactive for MIDI-Out. I’ve tried making active via Transport>Project Sync which makes it show as active as an out in Studio Set up, but still no midi data so I’m at a bit of a loss what else to try - (already done the old disconnect/diff USB port tricks).

Its strange as it only seems to be an issue in some legacy projects I’m loading up on the new rig, so its possibly something obscure/obvious I’m unaware I need to activate (possibly within the Transport>Sync?) or something else but any insights on what to try would be gratefully received.

Thanks in advance!