Midi controller track assignment

I need a little of your help guys. I tried solve my issue myself but looks like I’m missing something.

Let me explain what i want:
I have a NI Maschine drum controller which i want to use with Groove Agent. So I made a track with GA and assign Maschine midi out as input for that track. It work perfectly till I have selection on that track. As soon as I select other track it stop working.
So basically I have to select keys track when I want to play on my key controller and select drum track when I have to use drum controller. This is not good and I know there definitely should be way to ignore that selection.

Simply put, I want to play drums by my one hand and keys by other one How to configure it?
Is there is some settings to ignore channel selection or something like that?

Thanks in advance.

  1. Make input on MIDI/Instrument track “All MIDI Inputs”. That way, you don’t have to change inputs when going from keys to Maschine

  2. go to preferences and remove the option “record enable on selected track” (or something like that–can’t remember the exact wording). That is what is making it “stop working” when you select another track. With MIDI, the track that is record-armed gets the input.

So now, if a track is armed to record, it will stay that way when you select other tracks. Then just arm record on tracks manually when you want to record/play into them.

This is exactly what i need. Thank you!