Midi doesn't switch to "Marker 1" VST 2.0.20

Hello,
I can´t switch to “Marker 1” (which I use as song-start) per midi footcontroller.
I could do it 2 days ago, didn´t change anything and since yesterday it won´t work nomore.
the same button works for other oder like winding forward but not for “Marker 1” or “Marker 2” (row 7 and 8 in Actions and Shortcuts).
Any idea?

Data2 from and to are both set to “1”, so it will only ever react to that. Is that the intention? Maybe try to set “Data2 To” to 127?

GREAT !!! THANK YOU !!! it works now…
I never really understood “midi” in the deeper way it works.
I just press “learn” and pray.
One more THANX for this very fast help!

Sorry…I´m unhappy again!
It worked for a few hours and then the same failure appears again:
“Marker1” can´t be choosen by midi footcontroller, allthough Data2 To is set to 127 (wich helped in the afternoon!).
And again : Its not the FCB 1010, because I can program the same button to another function like “wind forward” e.g.
what is it???

Is transport started? Then you cannot locate. Is Marker 1 (Left locator, “L” in the timeline) set to a position that is reachable, i.e. not after Song End and not before right locator “R”? Does pressing “1” on the numeric keypad (“End”) work, as it is the keyboard shortcut for the same action?

What I do is:

  1. I start the song (Marker 1 is startingpoint / Marker 2 is endpoint)
  2. I stop it (somewhere between the markers) and it jumps back to ZERO
  3. I press “row7” to get to Marker 1. And this works by pressing “1” on the laptop but not with the midi information!
    Now…as I started my work this morning I tried this:
    In the “Action and shortcuts” I reset the page “Transport” and programed it once again with those 3 orders…and that worked for 2 hours.
    Then I edited something in a lyric-track pressed STR+S to store and the function “Marker 1” stopped working ! It “seems” to me that the storing or editing has something to do with the malfunction, but it could also be just a matter of time.
    Now I tried to reset and program once again on the “Transport” page but no succes…I can not reproduce the solution from above…
    Please…please…please…and thank you for taking care of my problem!

Update:
Now I rebooted the laptop and the midibutton for “Marker 1” works as it should alltough “Data2 To” is set to 1 like in my first screenshot.
hmmm? why is the function leaving? I’ll watch it from now on with every step in editing or storing and keep you up to date.

Update:
I’m not happy still!
Still the command “go to Marker1” works just from time to time by the midicontroller. I changed the midi-cable, I changed the midi device and I changed to USB-Input…it’s still the same…sometimes it works and sometimes not and I can’t find the cause.
It ALWAYS works by the shortcut from the keyboard “Num+end” !
I have to load another projekt (and then close it) and then load the “right” projekt and then it works. But this is not always the case. I have to do that procedure a few times until I´m lucky to get my “switch”.
Any other command works but not “Marker 1”
I even made a new inatllation of VST live Pro 2 and of course I am on 2.0.24.
The thing is that my songs don´t start at the 1.1.1.1 of the track because of count-in or some videocontent. so if I want to stop and start again I HAVE to set it to the defined starting-point which is Marker 1.
I’m quiet sure that it is some kind of bug.
As mentioned I tried everything that I know…
…any idea?

Had a similar case and it turned out that the MIDI message was assigned twice (allowed due to user request). Pls check if the same MIDI device and status/controller are assigned elsewhere.
The other potential pitfall is that when you learn a MIDI message, Data 2 is initially set to the recorded value. If it is a note on, for instance, it will only work for that particular velocity. You need to set Data 2 from and to to 1 and 127 resp. in that case.