MIDI Dropout issue after upgrading from 9 to 9.5


My computer, admittedly, isn’t a tank, and I’m slowly working through the process of optimizing my machine as an audio workstation, but until now, I’ve dealt with the occasional audio dropouts I run into in Cubase 9, but with the update to 9.5, which I would love to be able to use, I’ve run into a critical issue.

When I’m playing through the timeline, audio dropouts cut all MIDI data every time they happen. If I’m holding any notes out, they all stop. It’s not a hard cut, rather they all receive note-off triggers and the notes release naturally after the short dropout. This happens whether or not I’m recording onto the armed MIDI listening track or not. Before the 9.5 update, these note-off triggers would not happen, and notes would continue to hold out with my input.

Even more annoying, when I’m recording, these dropouts will end recording completely.

Is there a setting somewhere that was introduced with 9.5 that’s causing this to happen? I’ve searched through several preference dialogues and can’t find anything and I’m worried this is a new function hard-built into Cubase.

To start this thread off, I’m not looking for any advice on optimizing to prevent audio dropouts as I am addressing that separately.

Any help is greatly appreciated! :exclamation:

Hi and welcome,

Is you Buffer Size big enough?

I’ve extensively tweaked my settings. Let me clarify: my problem isn’t the dropouts itself. It’s the way Cubase now acts when dropouts happen in 9.5 vs. 9.0 that’s causing me issues.

I stream working in Cubase using OBS, VoiceMeeter, and YouTube Live, and occasionally, small dropouts happen (and I’m okay with that).

My issue is that in 9.5, Cubase now cuts my MIDI input when a dropout happens during playback. This did not happen in version 9.0. I’m trying to understand if there is a setting somewhere that was added or toggled on in the 9.5 update that I can turn back off.

I’m probably going back to 9.0 if this is just a new hardcoded feature of 9.5.

Bumping this thread to see if any new ideas have come out :frowning:

Alright, I’m going back to Cubase 9.0. What a bummer. Everything else about the update is great but it’s basically unusable in my streaming configuration right now because any dropout halts my MIDI input. :confused:

I have a similar issue, audio drops out very frequently and stops recording too. This has been happening only recently, after I upgraded from 9 to 9.5 - and several solution options I saw online did not work for me. Have been Steinberg user since Cubase 5 - this is the first time I feel I should question my confidence in the product. Anyone has any idea how we can solve this? Can’t do anything - can’t work like this :frowning:


Could you try to increase the Buffer Size of your Audio Device?

I had the same problem in Cubase Pro 10 on Mac. Midi recording dropped out and stopped continuously during recording due to system overload and audio dropouts. I changed the buffersize on my audio interface from 256 to 1024. That fixed it for me