Midi drum clips not lining up to grid

Hello I’m using Ezdrummer and having problem lining up clips to a 4/4 measure, the grid is set to Snap #1000 ms.
I tested the Grove Agent and it has the same problem.
Also the Pre Roll is not allowing me to Pre roll a count in of 8 beats.

When I put a new midi drum clip on the track it snaps to the grid and is overlapping the clip in front of it and I have to set the grid to snap to Events.

I tried deleting the preference file and the shortcuts xml file and nothing works.

Does anyone know how to fix this? I don’t know what happened Cubase was working perfectly, now it’s a complete mess.

Thank You

Similar problem here - I drag a drum loop from the media and it doesn’t sync to the grid. Even when I put the BPM in the session to match the bpm registered on the loop, it still doesn’t line up and sync.

Hi Alexander78

I fixed it but still not sure how the Bar # was showing 10 to 1000 ms that was probably the problem as I can’t select anything to make it show that again. So what I did was a complete reset of Cubase by following a Cubase article found by searching “Safe Start Mode - Resetting The Cubase Preferences” for some reason I can’t post the url here.

Either hold down Ctrl + Shift + Alt and double click the Cubase icon on the desktop or go to the start menu and search Cubase and then hold down Ctrl + Shift + Alt. Select to Delete program preferences, Cubase will then ask you to select your Audio interface and then show the Hub as it was when we installed Cubase for the first time.

The midi drum clips line up now and the overlapping problem is gone. When I drag a new clip onto the track it goes where it is suppose to and snaps to the bar correctly.

I still can not double click with the mouse in the Pre Roll box and set the count in time, I have to right click to make it editable, that’s weird now.