Midi Editing Issue [SOLVED]

Hi all!

I am having an issue with the midi editing in my version of Cubase Pro 8. Essentially, I can open up the midi file for editing just fine; however, if I delete a note, all the subsequent notes afterward are shifted to the left by some value (usually based on the quantize). It kind of reminds me of pressing insert in Word or something…

I’m note sure if I have just pressed some random hotkey by accident or what but any help in fixing this would be great as it makes composing a real headache.



Delete User settings data to restore Cubase back to it’s factory settings. (Source: Steinberg customer service rep.)


How do you delete the MIDI Note? Do you use KeyCommand or any tool.

Do you use StepInput?

Hi Martin,

I delete the midi note as I always have (dating back to Cubase 5)–with backspace. I don’t use any keycommands or tools for midi editing apart from backspace and the tools Cubase grants you after you right click and select a tool.

I don’t use step input.


Weird, I have in mind, that this could be somehow possible in Cubase. But I cannot find the way, how to provoke it (and than switch off). I’m sure, trash of preferences would help. But it would be nice to know the reason, of course.

Ye, I agree. I’ve already gone through resetting all the preferences to default but to no avail =(. Thanks for trying to help though–much appreciated.

Do you have Snap set to “Shuffle”?

Hey Vic,

Nope, snap is set to grid =.