MIDI Editor:Focus on playback cursor when opening a sequenc


Whenver i double click on a midi sequence it shows me the content at the start of the sequence, where i would like to show the content of this clip at the current playback position. Is there a way make this a default behaviour?


AFAIK showing the current playback position is default behaviour, unless the playback cursor isn’t on the event you want to edit. When you are minimizing instead of closing the event editors, it won’t focus on the current playback position after maximizing the editor again. Unless you tick Auto-scroll.

It doesnt behave like that here. Imagine you zoom in the arrangement view so that you only see the final bars of a midi sequence. Lets say the seuqence goes form 1 to 16 and rioght now on the arrangement becasue of the zoomming you only see the last 3 bars (14, 15 and 16) and the cursor stays somewhere between 15 and 16.
If i double click the sequence at this point it will show me the content starting on bar 1, not on bar 15-16, o i have to manually scroll inside the midi editor until i see my cursos playback again.

If this is not the normal behaviour, how can i change it ack to the default? thx.

Press F on the keyboard and it will scroll to the cursor. Press F again to turn off auto scroll, unless of course you want to keep it on.

I’m using to press F twice. First of them switch off the Follow cursor (which is On in my default settings), second one switch it On, and jumps the editor on the right place.

I made own preset with QuicKeys for this – open Key Editor, and press F twice.

True is, I hate this “un-linked” editors! :imp: Even though I check Linked editors in Preferences.

Yes i am doing the F thing twice. I just thought there must be something i missed on the preferences or something. Really weird this has not been considered by Steinberg.