Midi editor quantize - can't turn off in drum editor

I am trying to place midi notes at the cursor in the drum editor. When I do the note is being moved to an aligned position. This is not what I want. I have tried to turn quantize off, not highlighted. What am I doing wrong? I also tried to turn off snap to grid.

Turn off snap

Well that is the right thing to do… turn off snap. What happened?

Very weird. It is working now. I also found the snap to cursor option. It is working now. Before posting I turned the snap on and off many many times. It did not work. Now it does. Very weird.

uh oh