Midi editor stuck after a change in score from variaudio

Hello all,

I would like to ask you for your advice with following issue in midi editor in Cubase 11 please.

My project has just one midi track and if a do one change in midi editor - e.g. add a note - my CPU utilization raises from 2% to 23% and Cubase freezes for around 30 seconds. It happens even if no VST instruments are linked to the midi track or if I shorten it from 9 minutes midi to just keeping few notes.

The midi track has been created by using variaudio on a recorded audio track.
As the issue does not occur in a totally new Cubase project I think it is somehow linked to the flow including variaudio translation from audio to midi.

Thank you all in advance for your support.
ZJ

Specifics
Installed software: Cubase 11, Cubase 5, Dorico 3.5, Play 6
Processor: Intel(R) Core™ i7-9700F CPU @ 3.00GHz 3.00 GHz
Installed RAM: 16.0 GB
System type: 64-bit operating system, x64-based processor
OS: Windows 10 Home

Hi,

Does it happen, if you delete any note? Does it happen, if you delete the note even in the Key Editor (or other MIDI Editor)? What Output is connected, if there is no VST Instrument selected? Is it a MIDI track or an Instrument track? Is it reproducible with any project (or any MIDI data generated by using VariAudio), or one specific project only?

Hello,

the issue persists no matter if I delete or add a note.
Yes, I detected this issue within score editor first but later saw that it happens even in MIDI Editor.
It is happening within the MIDI track and even if output is set to “not selected” option.
I tried a new project, used VariAudio without any adjustment and the issue was not present in it. Thus, I think, it is caused by AudioWarp because I did quite a lot of timing adjustments to the original audio record by AudioWarp.

What do you think please?

temporary link (video showing slow performance):

Hi,

Sorry, on the video, I don’t see when the CPU usage was 2% only. I can se around 20% for all the time.

It would be interesting to Bounce the Selection after the AudioWarp, if this would fix the issue.

Hello,

I made a new video where you can see CPU/memory utilization all the time - and also the 2 %:

I made also video in which I skipped using AudioWarp and the performance is alright.

I tried to bounce the audio track with having already applied AudioWarp but the issue issue persisted: 2021-05-12 16-29-07 AudioWarp+Audio Bounce selection.mkv - Google Drive

I think that AudioWarp is causing the issue even though I have also positive experiences with it in other projects.
In this project, I did quite a lot time-warp, sometimes shrinking redundant notes not to be audible but nothing seemed to be doing troubles, overusing CPU nor crashy until I wanted to edit its MIDI translation.

Thank you for advices.

Hi,

Sorry, I was watching 6 minutes of loading Audio file and detecting the VariAudio. Then you inserted random MIDI Notes, then you select random MIDI Notes and deleted them. That was it.

What should I see, please?

Hello,

The first video visualizes the issue from its 3rd minute.
It shows that just a single adjustment in the MIDI editor increases CPU to 25 % and freezes for around half a minute, so nothing can be edited.

The second video shows how smooth performance should look like in my setup at 6:10. In this video, I skipped using AudioWarp.

Third video refers to following your advice to use bouncing. Unfortunately, it did not resolve the issue.

Thank you in advance for any other suggestion.
ZJ