MIDI events; note 'blocks' - display scaling

Is it possible for me to stop/change/alter this display scaling of the ‘blocks’ representing notes inside a MIDI event, on the Arrange Page…? To demonstrate in the screen grab, I’m splitting the event at Bar and then using CTRL+Z to undo, so I can repeat for the camera. Why it scales the left-hand portion, yet doesn’t equally scale the (new) right-hand event after the split, I don’t know…

The MIDI event itself came from an earlier edition of Cubase (looks much nicer to me; gives better visual feedback as to the event contents too).
C7_5_10_Midi event display scaling.gif
Track height makes no difference; anyone any clues please…?


Hi Bob

Does the event to the right have a wider note range which is off-screen? If so, that would explain the lack of scaling change. The vertical scaling is made to “optimise” the view, so it’s as zoomed in as possible.

This, for me is one of the most idiotic ideas I’ve ever seen, it completely removes the ability to understand the relationship between MIDI events, and if it can be turned off, I’d love to know how.

I haven’t noticed this scaling discrepancy, but I’m not too keen about the auto-scaling either because it means that when I move +/- an octave then I can’t tell whether it’s worked or not because the notes don’t move anymore… So I reckon I preferred the old representation.


Hi - no, the subsequent event created to the right (after doing the split) has exactly the same note range.

Having thought a bit more, I can recall this ‘vertical scaling’ of the display coming into being a while back (yes, it was to ‘optimise’ the view…!). Really don’t like it; don’t remember ever liking it… Now, even more so as I’m reminded of how elegant and useful, visually, this used to be.

I think they went, with all good intention mind, just beyond the point of it being a useful improvement…(I think it was done for those who complained when they are sat a good few feet away from monitor).

And yes, it does completely remove the ability to understand (visually) the relationship between MIDI events (musically).

Frankly, I don’t fancy starting a long debate asking them to consider an option in preferences, to turn it off. Life’s too short…

(don’t even get me started! :stuck_out_tongue: )… +1

Not just me then. I remember being attacked for criticising it in the past.

It’s one of those things that someone might think is a good idea until they think about it in practice. It’s actually possible for one part to look higher in pitch than another depending on where the notes are placed, completely ridiculous, and it means that octave-displaced parts (which I often use) look identical visually. Idiotic, IMO.

I’ve tried to recreate your issue here, but it doesn’t do it, it works as expected; if you export the MIDI of it and then re-import it to a new file, does it do the same?

Thanks for checking…

No, you can’t recreate the behaviour, right inside C7.5.10

All Midi recording/editing done from scratch behaves ‘normally’ (albeit with the inherent ‘scaling’ of the block display). The project in question was started in (I think) C4; the blocks and display scaling stuff came at v6.x.x or so, along with removing the lower event name label area in all events/parts (mostly blank space). IIRC…!! :wink:

I just tried an export/import in C7.5.10 of that whole event and it made no difference; the file imported without the display scaling and if I split it, then the behaviour is as seen before in my attached file.

Thus I’m surmising that the display scaling of these blocks seems locked to the event (as generated from the version of Cubase it was first created). I would guess, as soon as I split and re-save, I will never see that ‘re-scaled’ display (left-hand side in my attached file) ever go back to the original ‘look’.

I’m sure SB are no longer concerned; they’ve been all round the houses with this before, and they believe they have their solution in place - as per user requests… Really though, I can quite understand, that there’s much more serious stuff for them to be looking at. Now that I’ve seen the light, as it were, would just like a quick way of turning it off… that’s all.

I don’t think Steinberg has ever been concerned - certainly in 20 years of working with Cubase I’ve never seen anything to show that they are…

… I don’t expect it to be removed, but what I would expect when making a feature like this is the option to turn it off in the preferences. Main reason I know that it’s idiotic is because every kid I teach asks why it’s like that!

Bump up (for next update - after 7.5.20 - I see no change noted there)…

It would be great to have an option to (turn off) revert to pre C6 scaling of the note ‘blocks’ display inside MIDI events on the Arrange Window please. The way it is now, it really does make it impossible to quickly discern/see at a glance, the relative correlation (musically) between one event/instrument and another… Like you used to be able to… :wink:


(This should be moved to FR page please mods)

+1. :slight_smile: