MIDI export glitches via Audio Mixdown - "random" sounds

Hi there,

I’m trying to export a single MIDI track (with Halion Sonic SE2 instrument loaded) as a *wav file using Audio Mixdown option. The output file is studded with random sounds as if some sounds of the original performance were randomly scattered throughout the recording. The ASIO Guard is on, and the input latency is 96 samples (5,057 ms). NB. The MIDI track can be flawlessly played back in Cubase AI - it’s only converted *wav that upsets me.

Should I try increasing the latency, or does it have something to do with the rest of the settings?
Thanks for your comments and help.

My HW/OS: UR 22mkII, Win 10-64 bit.



If you export out of real time, the latency is not taken in account. Try to export offline.

If you get the sound even then, make sure you are not using any 3rd party plug-in in DEMO/Trial mode, please.

Hi Martin,

Thanks for your comments.

The Real-Time Export box has always been unchecked.
No, I’m not using any demo/trial instruments - just the instruments/effects that were bundled with my Cubase LE AI Elements 9.
I’ve tried increasing the latency to 128 samples, made a new recording of a similar length, ~ 12 min., and the converted file turned to be OK. But there was a small drop-out in the original MIDI recording. It seems that the buffer size makes the difference of some sort. :confused:
Is it true that the more the buffer size is, the more drop-outs of the live recording I will experience?

PS. The converted (exported) files are saved to my external USB 3.0 HDD. Although the state of the drive is perfect, what if the transmission of the processed data in the ‘master’ SSD to the USB 3.0 HDD brings about the glitches?


The drop-out cannot be in the MIDI. The drop outs are alway while real-time processing, when the CPU is not powerful enough.

Actually, you (almost) cannot run in the situation, there are drop-outs in the recorded signal. This could occur on Audio signal only (not MIDI). If this happens, Cubase informs you and stops recording. So you have drop-outs while playback in real time, what is currently recorded.

No, increase Buffer Size doesn’t mean more drop-outs. It means, there are bigger block sizes, so the computer needs more time to process it. From the user point of view it means there is higher latency. But while playback, you will get less drop-outs with higher Buffer Size.

Can you hear the glitches/drop-outs on the exported WAV file? If yes, then the issue is not in the Buffer Size. If yes, where do you play back the exported WAV file?

Hi Martin,

Yes, I can. The files are played back with Media Player Classic on the same PC.
I recorded another file without altering any settings, and this time everything went smoothly… :confused: