MIDI export with no tempo data


I use cubase pro 8.0.40 (last update) with a mac - Sierra 10.12.3

I export tons of midi files and then import them again to new projects or to a different app -
and usually it goes perfect with the tempo track and the included data.

For some reason, I’m having a problem with some projects - the midi exports doesn’t include the tempo.
Not the fixed tempo, nor tempo track with or without changes (when I import to a new project it’s always loading it with default of 120 bpm, regardless of what was there in the export)…
All export and import preferences are exactly the same, as well as project setup.

I also tried importing these specific midi files to a new project, changing the tempo manually and then exporting again - same result when I import it back to a new project - 120bpm.

The only thing that sort of worked there was importing a “good” midi file (a one that cubase is reading its tempo), and then copying the midi I wanted into this track and exporting.
But when I tried to change it to another fixed tempo it didn’t work again :confused:

Again - 90% of my Midi files are imported correctly, and I can’t point at something I did different in those projects. Feels like a bug to me, but I want to make sure I don’t miss anything here…

any ideas?

Hi and welcome,

Are you sure you import the MIDI file to a new project then?

Tempo track is not applied, when you import it to the existing project (doesn’t matter if there are multiple Tempo events in the project, or if there is just one init tempo event).

Hi, thanks

Yes I’m aware of that, I always import to a new project (import midi–>create new)

Actually I also called my local distributor and they didn’t know what to say - except they also suspect it’s a bug.
They also mentioned that maybe there was some similar bug in a previous version of Cubase 8, but they couldn’t recall exactly what was it…


Could you share some of the problematic MIDI Files, please? Via PM, if you don’t want to make it public.