Midi feedback loop Mackie Control over ipMidi

HI All,
I’ve been using ipMidi and Mackie Control to control my SSL Sigma summing boxes for many years. This stopped working all of a sudden. I’ve tracked the problem down to a midi feedback loop in ipMidi. When I set the MackiControl devices to “not connected” the loop goes away.

Of course I need to set the MackiControl devices to the appropriate midi channel for them to work. Any thoughts on how to fix this problem would be GREATLY appreciated.


Make sure the midi ins/outs going to your Mackie Control are not enabled in “In All Midi” in the Midi Port Setup

Thanks beatpete but I already checked that. This setup has been working for years. I really don’t know what could have changed to cause this issue.


I don’t know, if this is the same case, but loop midi makes the loop from in to out. So to make it working properly, you have to use 2 independent MIDI Ports.

  • Port 1 as an output
  • Port 2 as an input

If you would use the same MIDI Port (Port 1 for example), this would make the loop.

Thanks for the response Martin. Interestingly if I do what you say, the loop does go away BUT…

The SSL Sigma using ipMidi is designed to work with input as port 1 and output as port 1. If I do what you say I can’t control the Sigma from Cubase. BTW: I’ve been using the same ports in and out
in this application for 9 years without a problem until now.

Something has changed in my system but I’m not sure what would have this effect. I did recently upgrade to Cubase 11 but now 10.5 also has the same problem. I also had to make some windows updates but windows shouldn’t have anything to do with ipMidi.

Anyway, I really appreciate you trying to help.


Try to disable the Preferences > MIDI > MIDI Thru Active option, please.

Thanks again Martin but this did not help.

FYI: I recently upgraded to C11 but I don’t think that is the problem. I don’t think it started then but I can’t be sure. To test this though I brought up a project in C10.5 and the issue was still there.

Also I disconnected my computer from the internet in case there was some interference since we are talking about midi over IP. Again the problem was still there.

Any more ideas?


Why does the SSL Sigma requires using the Port 1 as an Input and Output, please? Could you point to the manual, or send me a screenshot from the application, please?

From my point of view, it doesn’t make sense at all. This would really just make the MIDI loopback. I don’t see any reason to do so.

What happens, if you set Port 1 and Port 2 and do the same settings in Cubase, please?

“loop back” is unchecked in ipmidi’s settings?

Yes, loop back is unchecked.

Hi Martin,
It may not make sense but this is how I’ve done it for 9 years. See the attached screen shot from the manual. Also I did try your port idea. This fixes the loop but does not control the sigma. The ports have to be the same as the instructions specify.
Thanks for your interest.


Did you update the ilmidi recently by any chance?

Could you (just for fun) try to enable and again disable the “loop back” option in the ipMidi’s settings, please?