MIDI Feedback Loop when using External Synth, MIDI Thru


Recently started using a few external synthesizers in Cubase 6. I am running through a MOTU Lite MIDI unit (which plugs in with USB).

The issue: I have the synths set up as External Instruments. I have a MIDI track set up: IN from port 1 on the MOTU, OUT to port 1 on the MOTU/the external instrument. While tracking, everything doubles up-- while I’m playing, it records the MIDI information all good, but then at the same time it sends back out the same information to the synth again, so I am hearing notes twice on top of each other. Playback is all good. I especially noticed this as my voice only has 6 voices. But in this instance… 3 notes = 6 voices

I would disable MIDI Thru in the preferences, but then it seems I am not able to hear VSTi’s during tracking… though once again, playback is all good on everything even when trying that. If there is a way to disable MIDI thru and still be able to hear VSTi’s while tracking, that would seem to be perfect.

I swear I had this working for a second yesterday, and now all of a sudden, it isn’t again-- maybe someone else will give me some ideas of what to try. Is there a way to filter MIDI on a channel/track ONLY for MIDI output back to synth during tracking? When I use the Input transformer, it completely filters the MIDI so that recording MIDI on the track does not work… though I swear using that was how I ended up making it work for a second in the first place.

Please let me know if you need any more info/can help. Thanks.

(Posted this in the Cubase 6 forum as well because that’s still what I use mostly, but also have Cubase 8. From what I saw in settings in each they were the same but maybe something can apply here too.)

Hi, you have to set “local off” on your external Keyboard.

Regards, Ernst


Thanks-- your post helped me fix the problem. I had tried Local Off on the keyboard before, and notes themselves were working, parameters were not (filters, resonance, etc.). I found a “Parameter Transmit” option on the keyboard was defaulted to OFF. I set that to ON, with Local Off also enabled, and everything works great now. Thanks again.

Hey you, i am glad I could help - at least somehow.

All the best, Ernst