MIDI file export is missing tracks

When I export a MIDI file out of Dorico 4, I’m finding a couple of tracks missing.

In my Dorico score, I have these four percussion tracks:

Screen Shot 2022-08-12 at 10.02.09 PM 2

But after exporting the MIDI file, then importing it into my DAW, the only percussion tracks I have are these:

Screen Shot 2022-08-12 at 10.02.18 PM

Any idea where the bass drum and cymbal tracks are? Yes, those tracks do actually have notes in them. (Note: I’ve never actually heard them play in Dorico, which may be a clue, but it’s one of my lesser problems in Dorico so I haven’t tried to troubleshoot this yet, but I’m mentioning it here in case it’s relevant to why the MIDI isn’t exporting.)

We’d need to see the project file itself to be able to offer any sensible insights.

Thanks. I duplicated the project and stripped out most of the unrelated notes so it could be cleaner and smaller. I’m now attaching it to this mail.

And if you could possibly indulge one more question, I posted in a separate thread that in m49, the very first beat, double bass: there’s a missing quarter rest, and I can’t figure out WHY it’s missing. I didn’t do anything to make it missing. If I delete the measure and re-enter the notes, that first rest is still missing. So I’m stumped on that too.


test file.dorico.zip (1.8 MB)

I can’t help you with the MIDI issue, but I have an answer regarding the missing crotchet rest: the whole bar rest in the preceding 2/4 has the property ‘ends voice’. Either uncheck this property in the properties panel below, or (better) simply select and delete this rest, as it appears to be an explicit one (i.e. manually entered), which is probably unneeded. When deleted, it will turn into an implicit rest that you can’t select anymore.

Yes, I think it is relevant! Your Bass Drum and Cymbals are not routed to any VST.

If you reapply the HSSE+HSO(pro) playback template routing will be applied and the midi file will be correct. Note: for some reason (unknown to me) the HSSE (Elements) playback template does not work (and routes these two instruments to ‘—’)

Janus is correct that Dorico won’t export any notes that it can’t play back, and in particular for unpitched percussion it needs the percussion map to be set in order to know what MIDI note should be output.

Thanks all! This did indeed get fixed by reapplying the HSSE+HSO(pro) playback template. Not sure how this was not originally assigned.

@PjotrB thanks for your solution to the MIDI issue - you were correct. Not sure how that crept in there, but it’s fixed now!