Midi file import problems

Hi just taken the jump and bought cubasis but finding that midi file import is not working.

I can import a file fine into mediabay.

The same midi file works in bs16i and music studio fine bUt in cubasis it plays some tracks, other it misses notes, tempo is up and down …

Anyone having similar problems?

This on an Ipad 4


thanks for your report. Could you be a little more specific about the issues that you are experiencing? What do you mean by “tempo is up and down” or by “it plays some tracks?” Maybe you could send me the files that are causing problems or a more specific description of the issues? Then we can provide you assistance or address this issue in an update.

Kind regards,

Hi thanks for the prompt reply.

Tried again tonight in a bit more structured fashion.

I exported the midi file from bs16i as a wav file and imported into cubasis to marry with the same midi file already imported as a new project. This matches. I also did a mixdown of the midi tracks only within cubasis and reimported into cubasis again this matches. So far so good.

Tempo appears to be stable tonight but this may have something to do with me using virtual midi to drive some external synths before -I will look at that a bit more.

The first obvious thing is the drums to not map to GM standard. Is this planned? Using studio kit btw. This may be part of making it appear the tempo is wayward?

The midi file is http://www.free-midi.org/song/pet_shop_boys-west_end_girls.html

Thanks for now.


I tried the MIDI file that you sent. What appeared broken to me were the drums. I enlarged each note by 1/32 (double tap in the MIDI-editor to select all notes) and now the drums sound fine. Did this solve your problem? If not please let me know.

Kind regards,

Hi, yes this seems to have sorted the drums out. I’ll try out the other midi files to see if this is the same issue.

I’ll try again with driving external synths as well and see how we go.

Thanks for your help so far.


let me add that the problem was not due to the MIDI-file but due to a bug in Cubasis. Very short MIDI-notes with a length of one tick are not played back most of the time (as in the file that you attached). This will be fixed. Workaround: Slightly extend the notes.

Kind regards,

Hi, thanks for being honest :wink:

I have used this midi file in the past so I know it should be ok.

Keep up the good work and look forward the the updates especially audiobus (hint hint)