Midi filter doesn't work

Although I already filter the pitchbend on both record and thru, it still gets recorded at the beginning of the recording. It looks like the midi filter is too slow to filter the initial recording. Does anyone have a solution?


What exactly do you mean by “at the beginning”? How do you provoke the issue, please?

Please try to describe it in step by step manner in details.

My midi keyboard’s pitch bend is so broken. It just keeps sending data even though there is no one touching it. So I turn on the midi filter. And then, I record some instrument tracks, and It always sounds out of tune. So I open the editor, turn out there is still a point in the pitch bend column at the beginning of the recording. Now I have to remove it manually after every recording.


Add MIDI Insert Monitor, please. Can you see any incoming Pitch Bend data, please?