Midi filter on instrument track inputs?

Hi All.

Returning user here! I’m sure it’s really obvious but I can’t seem to figure out something. I have a hardware sequencer sending midi on 9 channels to Cubase 6. I’ve set up 9 instrument channels for various synths and I assumed that I would set the midi channels to ‘any’ or restrict them to ‘x’ then dial in the correct midi channels on the sequencer but no sign of the ‘any’ setting so my vst synths seem to be receiving on all channels. I’ve been using the logical editor to filter the unwanted channels but there must be a simpler way, yes?

Use MIDI tracks.

Thanks for the reply but I have tried that. Irrespective of the midi channel setting, all synths are receiving in omni mode, whether as midi or instrument tracks. I’ve been reduced to using midi patch bay and the IAC in OS X to create channel filters between the Sequencer output and the inputs of Cubase, it’s not ideal but it works. Surely, this cannot be the way it is with Cubase, Live has channel filters right there and easy to see. IS there a midi channel filter vst widget I can put in the insert?

You would do this with a Local Input transformer on each track.

Set the filter target to

Channel   |  Unequal   |   <channel number>

and set the Function (at the very bottom) to Filter.

Action target can be blank.

Don’t forget to turn the module on!

Hey Steve.

Thanks for that, I figured there would be something like that that I could do it with but assumed that there would be an easier, specific channel setting somewhere, as Live has. Just seems a bit of a kludge to me.

The way it works in Cubase is that you set the VST instrument itself to receive on a specific channel, and you set the Instrument Track to any.

It appeared you couldn’t, or didn’t want to do it that way, so I proposed the input transformer.

I’m looking at Mystic now and I simply cannot see a channel setting anywhere. Massive and Halion obviously do but some of these Steinberg VSTs seem not to have it.

Mystic only receives on one channel– the setting would only be found in multitimbral (e.g. multi-channel) VSTs.

I’ve just fired up Mystic and set the input to ‘any’ and not to ‘all midi ins’ but to the keyboard I’m sending from, then transmitted on channels 1,2 & 3 and it appears to respond to all 3.

That’s because Cubase automatically channelizes the signal.

If you want to filter out the channels in this case use the input transformer- http://www.steinberg.net/forums/viewtopic.php?f=19&t=60134#p363085