MIDI ghost notes that aren't really there

In the accompanying video (sorry, I don’t know how to do a screen video capture with sound) the sound you can hear is not actually there, as a quick check of the List Editor will verify. It is being triggered by the previous note that ends where the loop starts. I have shifted this note up 2 octaves to make sure the phone mic picks it up adequately and the ghost follows it, so it’s definitely the cause. I left the click on so you can hear that the ghost is slightly random. Note that MIDI Echo is off.

Shortening the note before the loop to .115 stops the problem. This workaround seems to be independent of tempo.

In another instance of something similar, a long note sounds at the start of a MIDI-free section for the duration of the loop. I dare say the same remedy will apply when I come across it again.

Any ideas what gives, anyone?


Is there any MIDI Insert involved on the track?

Hi, Martin. No, no MIDI Insert. There is a MIDI Send but switching it off makes no difference.

Changing driver to ASIO4ALL → SbLive makes no difference either…


How is your Preferences > MIDI > Extend Playback Range of Notes that Start before the Part settings, please? The default value is 0 Ticks.

Martin, you’re a genius! I never knew that option was even there. It was 5 ticks, exactly matching the gap I had to leave, but I don’t remember ever changing it. Never mind, it works.

Thank you!