MIDI, I'm way out of my depth here!

Gday all. I’m struggling with the MIDI side of things in Cubase. I hope I explain this properly…

I am trying to record some beats and keyboards using Groove Agent 4 SE and say… Padshop or HAL… what is happening is

  • I create a 4 bar loop
    *I select the correct IO of the MIDI
  • My Focusrite lets me hear the sound with no latency.
  • The mixer signals have no latency
  • The track however shows up the MIDI signals ( not sure that’s the correct term, the little dash things on a MIDI track. ) about 2 bars late and with a different length of sound and say I hit the key on my external keyboard at beat 1 bar 1 it will put a dash at say beat 3 bar 3 or something like that, and play back at that beat
  • It seems random…
    Am I missing something?

If I record the VST instruments by double clicking on the track and using the keyboard on the left it works fine. but that’s not want I want to do. I want to use MY keyboard!

Any help would be appreciated and I can clarify if you need more info

Cheers Matt

2 bars off seems a lot more than usually reported so maybe there is something more wrong with your specific system…but try these “usual” fixes first and we’ll take it from there

  1. Try use system timestamp in Device Setup/Midi devices
  2. Make sure you don’t have auto quantise on (transport midi record modes)

Thanks for tips again Grim! I am checking out for the night here in Oz but I’ll try those ideas tomorrow and report back then. Yeah thought it was a bit weird. My IO latency is at 6ms, if that makes a difference. Zzzz

Grim, you are awesome! Using the system time stamp worked! It is working perfectly! Thanks again mate. I’m getting there :wink:


TBH I’m really not sure in what circumstance you wouldn’t want this checked and why it isn’t just fixed as enabled…would like to know if anyone has any idea about that?

Let’s face it axematt we have all been there when we started using Cubase. I had exactly the same problem when I moved from the Atari to a PC. Keep at it.