MIDI import stops after a while

Dorico 4.1 doesn’t want to import this midi file (progress bar stops at 23%).
(all other DAWs I own open it without problem)
SYMPH_11.MID (67.3 KB)

It opens OK for me, I’m afraid to say.

It gets stuck at 23% here, too. Then Dorico hangs.

1 Like

Yes, I’m forced to kill Dorico in the task manager.

Very interesting. Could you please use Activity Monitor to sample the Dorico process, then save the resulting text file, zip it up and attach it here?

Sorry, I’m running Windows :frowning:

That’s OK, I’m hoping Leo will be so kind.

Here you go:
Sample of Dorico.zip (43.2 KB)

In the meantime, if you re-export the MIDI file from a DAW, can Dorico open that?

No (I tried to do this with Cubase, which opens correctly the file).

Thanks, Leo. I’ll take a look at this as soon as I have a reliable enough Internet connection to download the required debug symbols (I am literally at sea as I type this).

2 Likes

Safe trip Captain :wink:

1 Like

Sorry for the long delay in coming back to this one. I’ve been able to reproduce the problem with this MIDI file now, and have asked one of my expert colleagues to take a look when he gets a chance.

1 Like

Always happy if i can help to improve this awesome software !

We’ve had a chance to take a look at this, and we can see that this has highlighted a bug in our percussion import code, however, I think in this project, the ‘percu 1’ stave is being interpreted as a GM drum kit, but it appears to be either pitched percussion or needs a custom drum map (it has 30 different pitches in it, which makes me think it’s not a ‘kit’).

In order to reproduce the bug you need to set the quantization options for tuplets to be a 1/16th note and import the ‘percu 1’ track as a Drum Set. As a workaround, if you change the track to Sketch > Grand Staff then it will import without hanging (you can then convert the instrument to the desired type after cleaning up). The results for this instrument do look a little messy because m.70 contains two trills/rolls played at different pitches at different times, and Dorico isn’t able to recognise that.

Please find attached the original Cubase file. May be it can help to understand things. You’ll see that “percu 1” is a Cubase folder containing all the symphonic percs (pitched and unpitched).
symph_11.cpr (1.5 MB)

If you need to continue your work I opened your mid file in sibelius and rexport it in type0 (rexport intype 1 generate also the problem here).
hope it works also for you:
SYMPH_11_sib_in_out_type_0.mid (66.5 KB)

1 Like

Ah, that’s interesting. So Cubase has collapsed all those MIDI tracks in the folder into a single MIDI track. I’ve tried this in Cubase 11 and it has kept them as separate tracks. Which version of Cubase are you using?

I’ve tried importing this version of the MIDI file with the tracks expanded:
expanded.mid (39.6 KB)

with the following mappings (including some guesses:)

image

and this gives much more sensible results, including the timp roll in m71, but not the roll in the GC track, as the timing is a little uneven.

Thanks to you !

Thanks a lot. I used Cubase 7.