MIDI-IN but no sound from phones [Alesis io2+Cubase LE]


I bought an Alesis io2 Express to use as an interface between my digital piano and the computer. I plan to connect to Alesis from MIDI-IN and hear the sound from headphones connected to PHONES port. However, I have problem with hearing from the headphones. I dig the Internet and forums for days and I tried many recipes. No solution. :open_mouth:

I have Yamaha P-35 and connected it from MIDI-IN to Alesis io2 Express (MIDI-IN led is on). I chose the ASIO DirectX Full Duplex Driver as suggested in many forums and provided pdf file. When it comes to play, I see a red bar rising and falling when I stroke and release a key (which made me think that the signal safely goes to the card) but I can not hear anything from my headphones which is connected to the Phones port.

I can hear Windows system sounds with the headphone connected to Alesis, but it does not work in Cubase LE.

Any suggestion? All will be appreciated.


Hi and welcome,

  1. Connect also Line Out of your Digital Piano to the Line In of Alesis.
  2. In Cubase, don’t use ASIO DirectX Full Duplex Driver. If there is no dedicated Alesis driver, download and use ASIO4ALL driver.
  3. Add a MIDI track in Cubase.
  4. Add an Audio track, set it’s Input to Stereo In (which is set to Alesis In 1 and In 2 in the VST Connections > Inputs).
  5. Don’t forget to enable Monitor (speaker) button on the Audio track.
  6. Make sure, the output of the Audio track is routed to the Stereo Out, which is set to Alesis Out 1 and 2 in the VST Connections > Outputs.