MIDI input and note monitoring

I have my software configured for duration after pitch.

When I’m entering MIDI notes I only hear the note after I select the pitch. This seems odd, and I could have sworn it didn’t work like this just a few days ago. That I would hear the pitch the moment I pressed the MIDI keyboard, and not until I selected the duration.

If I’m not just having a senior moment, is there a way to have dorico play the midi before selecting the duration?

–Neil

Something is definitely wrong. If I switch to duration before pitch, I get no audio feedback.

–Neil

I was able to get the behavior I wanted by activating “MIDI Thru” in Preferences->Play->Recording.

I’m still confused, but it’s working now.