Midi Input and Step Input behaviour

When editing multiple instruments in the key editor, after changing instrument, the piano roll doesn’t work with Midi Input. In 9.5 it did.
I must first deactivate it and reactivate it. This also happens with Step input.
After changing instruments the piano roll doesn’t input notes but my midi device does.

Hi,

How exactly do you change the instrument, please?

Do you use Key Editor I the Lower Zone or in the window?

I change instrument by either selecting a note that is played by the instrument or using the list at the top of the key editor.
I use the key editor in the window.

Hi,

Do I understand it right, you change the MIDI part you are editing?

Do you have the latest Cubase 10.0.20 installed? Are you on Windows or Mac?

Hi,

Yes, when I select a note that is played by a different instrument or select an different instrument from the menu at the top of the key editor, it does change the Midi part that I am editing. This is when the piano roll ceases to work with Midi input or Step input.
I am required to deactivate and reactivate Midi input or Step input for the piano roll to work after changing instrument/Midi part.
In 9.5 this step was not necessary.

I have Cubase Pro 10.0.20 installed with Windows 10.

Hi,

Make sure the Record in Editor is enabled in the KeyEditor, please.

Hi,

Thanks for getting back to me.
Having the record enabled in the key editor didn’t seem to work.
Here is a video of what’s happening

https://youtu.be/H6Ym5sv4SKw

So any news on a fix for this?.

Confirmed, on my system as you say, and as you show in the video.

I am glad that this issue was confirmed but am not glad that 2 months and one big update later the issue is not fixed!.
https://youtu.be/H6Ym5sv4SKw

Hi Steve,

Did you make a Jira entry, please?

No, I didn’t.

Hi,

Reported to Steinberg CAN-24001.

Thank you Martin