Midi input broken

It seems that midi input (and recording) doesn’t work anymore while it works in D4.

Very likely some application configuration in your setup for D5.

Is your MIDI input device set up in Dorico’s Preferences > Play…?


Yes it is.

Are you on Windows, or macOS? If you’re on Windows, make sure that the Use WinRT MIDI checkbox in the Advanced Options section of the Play page of Preferences is switched off.

If this doesn’t help, please do Help > Create Diagnostic Report and attach the resulting zip file here. Simply saying that something isn’t working for you isn’t sufficient for us to help you sensibly.

Thanks Daniel. It doesn’t help. Record doesn’t work. Please find attached the diagnostic file.
Dorico Diagnostics.zip (472.3 KB)
I also noticed that the preroll with the metronome doesn’t take in account the written tempo at the beginning of the flow.

Hi @Axel , looking at the diagnostics, it shows me that in the Dorico preferences the option ënable MIDI Input" is set to false. I guess if you change that, it will work again.

Midi input is

enabled on the screen. But record doesn’t work. I can hear what I play on the keyboard, but no recording and no little green point flashing like in D4.

That what you show in the screenshot is not the right option. Please go to the Dorico Preferences dialog and there to the Play tab (if my memory is not wrong) and scroll down, it’s called ‘Enable Midi input’.

1 Like



Thank you. It was unticked. Is this the case by default (I never unticked this) ?

No don’t think so.


Strange. And very hard to find : when you strike “J”, it doesn’t appear.

Actually I believe it does: if you type “toggle MIDI input” you can effectively turn this option on or off.

1 Like

Oh damned ! That’s the problem ! Sure I have clicked on the item and said “it does nothing”… Sure it should be more ergonomic to bring the dialog box (because it’s usually the case for “J” items) or at least a confirmation. Or the usual blinking green point transformed in a fixed red point :wink: