MIDI Input Channel Filter available since Cubase 13

Hi,

Since Cubase 13 you can use the Channel Input.

Channel Input

Instead of Any, set the dedicated MIDI Channel for the given MIDI/Instrument Track, you want to listen to.

Moreover, unlike the Input Transformer, this feature is available even in Cubase Elements, LE and AI. :+1:

6 Likes

I assume this works interdependently for recording and playback. So if I record a keyboard playing on Channel 3 with the inspector set to 3, I could then change the Inspector to Channel 1 and that MIDI would now play on Channel 1.

1 Like

@raino
I have yet to upgrade, but am interested to know if this is the case…
Any chance you could post a simple Yes if it works as you describe “interdependently” Thanks in advance.
Kind regards.

Hi,

You are right.

1 Like

Thank you @Martin.Jirsak
I am looking in my wallet and the moths are getting restless.
Ta!

1 Like

Great function for me!!!
Thank you

1 Like

12 posts were split to a new topic: Now if only my Komplete Control S61 could transmit on anything other than Ch 1 (thanks NI)

This is a great feature, but I found that the setting is not saved with the project or else the setting is overwritten by “Any” when a saved project is loaded. Has anyone else noticed this?

I should add that I’m using MIDI outputs from other plugins when this happens, e.g. Scaler 2 for which you can choose different channels for feeding MIDI to an instrument.

1 Like

Hi,

I cannot reproduce this on my side. The MIDI Input Channel has been saved within the project.

Hi Martin,

Thanks for your reply. I’m on Artist (13) and can cause this problem with two different sender plugins. May I ask which plugins you are using (sender and receiver instruments)? I would like to try them or demos on my system, and see what happens.

One combination that didn’t work for me is Scaler 2 as sender and MSoundFactory as receiver.

Or did you just use an empty MIDI track? That seems to work.

I just checked MSoundFactory as Instrument by itself in a new project (no sender) and this doesn’t work correctly, either.

Also, I’m referring (just to be clear) to the second entry under Routing, not the fourth entry.

Hi,

I’m using MIDI/Instrument Tracks.

Could you describe your routing, please?

Hi Martin,

Thanks for your reply.

To show Routing:

I created a video. Video shows Create Empty Project, Add Instrument Track with MSoundFactory loaded, change MIDI input channel to 2 and the fourth Routing parameter to Channel 2, Save Project, Close Project, Reload Project: Shows MIDI input channel is now “Any.”

YouTube:

You can see routing in the video, but I would be happy to show whatever else you request.

Isn’t that the way it’s always been? The channel setting in the inspector forces all MIDI events to a single, defined channel. What am I missing?

It only used to do that only on Playback in Cubase 12. If you were playing a keyboard that was split so the left hand was Ch1 and the right Ch2 and Recorded the playing into a MIDI Part, that MIDI Part would have Notes on both Channels 1 & 2 recorded. This was independent from the Track’s MIDI Channel setting. That’s why folks had to use the Input Transformer to filter MIDI Channels. But now in 13 the Track’s MIDI Channel setting will filter what gets recorded. So in C13 if the Track was set to Channel 1 you’d only get the left hand. If it is set to “Any” then it would record like in Cubase 12.

1 Like

Thanks to raino for Reply.

The video shows the simplest form of the problem that I could come up with. A more complex situation is what I actually first ran into.

In Cubase 13, you can:

  1. Create an instrument track that uses an instrument (Parent) that produces MIDI outputs on multiple channels to be received by multiple instruments (Children).

  2. Create multiple instrument tracks, each to receive a single channel of input from the corresponding output channel of Parent.

  3. Assign the MIDI input device, first Routing parameter, for each Child to be Parent.

  4. Change the MIDI input channel for each Child, the second parameter in their Routing section, to match the intended output channel of Parent.

It works great. The MIDI data are all separated and routed to the intended Child. Each instrument plays one part.

But if you Save the project, then Reload it, all the MIDI input channels for all Children are reset to Any, and all instruments each play all parts, not just one part each.

The fact that it works two different ways, separated by a mere Save and Reload proves that there is a serious problem, at least here on my machine. The behavior should be exactly the same before and after Save/Reload when all I do is hit “Play.”

Hi,

This is new in Cubase 13. You can now set up even the MIDI Input Channel. This is the one, which is not persistent.

Hi,

Thank you for the video. Now, I can reproduce it too.

The setting is persistent for the MIDI Tracks, but it’s not persistent for the Instrument Tracks.

Reported to Steinberg. Thank you.

1 Like

Thanks Martin. I had also reported this to Steinberg Support USA, but not with persistent MIDI Track.

Previously in this thread, I did mention that an empty MIDI track worked, that is, was persistent, but I didn’t try recording anything in it after that.

Thanks again. I really appreciate your help.

I just reported this issue in the issues thread before finding this post.

I have tried saving a template with the input channels set on instrument and MIDI tracks, but when I open the template all of the instrument and MIDI tracks input channels default back to Any…

I will reach out to Steinberg support to report also.

Thanks all!

1 Like