MIDI input failure

Hey all, hope someone can help :slight_smile:

First of all, vital stats
Toshiba laptop, running Windows 7 64bit, Intel Core i3 Inside processor. 4.00GB of RAM.
Cubase AI5, latest version. Had it bundled with a Yamaha Audiogram 3 USB soundcard.
MIDI device is a Yamaha YPT200 keyboard with a USB-MIDI interface, first of all a cheap cable from Amazon, now a Yamaha UX16

Right, so a month or so ago, Cubase would BSOD whilst recording MIDI. I could record hours of audio if I wanted to, but it would crash within five minutes of recording midi input. The crash report blamed a driver belonging to another program, NCH Soundtap. After uninstalling the program, the driver still caused problems, and after some stressful attempts to delete that, finally got rid of it (not deleting anything else, I know futzing about with the registry is dangerous…). And now… no MIDI input. The transport bar shows no signal. Everything in Cubase seems to be in working order, ports are visible, right ones selected, cables plugged in right… nothing.

Have tried reinstalling the generic Windows MIDI driver, that didn’t change anything. Cubase support couldn’t help because I got it bundled with a Yamaha product. Yamaha support thought it was a driver issue, and suggested I buy the aforementioned Yamaha UX16. Having got this, Cubase sees it ok, the Yamaha driver is installed, and everything is in the right place… except I still have no MIDI input. I’m stumped!

Any help would be hugely appreciated!

Sam

Is the MIDI track monitor enabled? Plug the keyboard into another USB port and make it go through Add Hardware is it doesn’t by itself.

Still nothing… Everything is as it should be in Cubase. It just seems like nothing is coming in. The transport just registers no incoming MIDI signal…

Try the free MIDIOX (google it). It is a Windows application that allows you to see if the MIDI is making into Windows. It might help determine where the MIDI is getting cut off.
HTH
J.L.

Well now that says my Yamaha UX16 is suffering an ‘unspecified external error’. And yeah, no signal is coming in at all there. The cable is brand new, so it could be the keyboard? Sheesh… In the morning. Thanks for the help!

Just because a cable is new doesn’t necessarily mean it’s ok, still worth checking it.

Ok, so with both cables the same error message comes up. So all signs point to the keyboard…? Except I can’t figure out how it would have deteriorated so…

Did you turn on the device before starting Cubase?

Yeah… It doesn’t work usually unless you do that.

How on earth do you fix one of these keyboards? There’s no way to adjust midi settings on it - it’s just perpetually on.

Bump for more information


Got my hands on a Korg Nanokey that again, used to work but I haven’t used it with the computer for about 6 months. Same issues… So if no keyboards work, if no special midi drivers work, if reinstalling cubase doesn’t work… What the hell do i do? This is getting rather urgent.

You may need to use the Emulated Ports for the device. Look for enableemulated in the manual to see how to get them to show.

A screenshot of the MIDI window in Device Setup and the project window might help.

If I follow you correctly, you have now had problems with two different keyboards and testing them both with MIDIOX taking Cubase out of the equation. If I am correct, it seems like it has to be…

  1. Something Windows related to that registry change. Windows restore/repair/re-install may be needed.
  2. USB port problems. Try different USB ports and double check the correct/latest drivers. I am a little unclear as to your interfacing. Are you are using the Audiogram AND a MIDI interface or when you say the “Yamaha keyboard with a USB interface” do you just mean it is a USB plug to software interface? (i.e. NOT a physical MIDI interface). How is the Nanokey connected?
    J.L.

Thanks for the prompt replies - another thing to add confusion is that I just installed, for lack of any other solution, a trial of another DAW (Cockos Reaper) and the Midi Input works! It is still unresponsive in Cubase, though, and MIDI-OX claims an ‘unspecified external error’ still with the nanokey.

Jaslan, to clarify: With my Yamaha keyboard, the one in the first post, it is a USB to MIDI cable - it does not connect to the Audiogram, rather one end in the computers USB port and the other which connects to the back of the keyboard with MIDI in/outs. The Nanokey connects with a USB cable, no traditional MIDI in/outs on it. I’ve checked all the drivers, and they’re ok.


Mashedmitten, here’s a screenshot http://i1238.photobucket.com/albums/ff491/Hypehat/cubasescreenshot.jpg

You need to enable the Monitor button to see MIDI activity and hear live playing. Select the specific MIDI port and not All MIDI Inputs.

Still nothing - as I say, the two thin input bars on the transport also show no input.

Unless there’s some monitor setting I’m unaware of? You just turn it on at the track, right?

This is very similar to what has happened to my PC. Also Windows 7 64-bit. I have a Kontakt Audio 6 USB audio/MIDI interface and a Yamaha S70 XS keyboard connected via USB MIDI. The Kontakt came with Cubase LE 4 and the S70 XS came with Cubase AI 4. I installed LE first and then uninstalled in favor of AI. For both, MIDI worked initially, that is, the devices could be seen and MIDI data flowed. However I was getting random BSOD with anything where I used MIDI, especially when I exited an application.

As atomiklust reported, I also had NCH SoundTap applications and the BSOD was referring to the stdriver64.sys driver from those applications. SO I uninstalled all of them (via Control Panel). Now I have no MIDI response whatsoever. Nothing is recognized. The devices all show in Device Manager, Control Panel, etc, but the applications don’t actually seem to pass any MIDI information at all. Very strange.

Have referred it to Yamaha also, but so far they are stumped. I’m going to see if I can run this by the folks at NCH since it was their driver uninstall routine that seems to have caused the problem.

Anyone got any ideas?

i also seem to have the same problem with this as i installed sound trap then got BSOD after a days use, sorted the problem now my midi is not working within cubase nor protools. but yet it works with my VST standalone plugins???
very strange indeed.

if you find a fix for this please let me know!

Similar problem here. ‘All midi inputs’ (both USB and virtual keyboards) had always worked up until 5/11/2012. Also have the same issue where All midi inputs work fine in a standalone vst. Found some great sounds, but now i can’t record them. There were some Windows 7 automatic updates around that time, I don’t know if that is a factor.