MIDI input problem with Cubase 6.5

I have both the 64 and 32 bit versions of Cubase 6.5 (fully up to date) installed both on my laptop and on my desktop machines. The set-ups on both machines are (or ought to be) identical. The MIDI input problem which I am about to describe is common to both machines although the Scarlett hardware set-up applies only to the laptop set-up.

I am using an old Casio keyboard with MIDI in/out capability as my MIDI controller. I am using a Focus Scarlett 18i6 USB as the audio/MIDI interface between keyboard and laptop. I have the latest versions of the Focusrite driver and software installed. I have got everything working fine in the 64 bit version of Cubase. The keyboard is happily driving VST instruments such as Halion and I can hear, record and playback through the M-Audio monitors connected to the Scarlett.

It is a different story with the Cubase 32 bit version however. Although any existing MIDI tracks play back fine, and although I can hear input from the integral keyboards in Halion etc, I cannot hear any input or record any MIDI tracks using the keyboard as input controller. I can see from the Transport window that input from the keyboard is reaching Cubase from the Scarlett’s MIDI port, but for some reason that input is not reaching the armed Cubase track.

I should say that recording/playback of audio tracks seems to be fine in both versions. I am routing live instruments and vocals to the Scarlett inputs via an oldish but still sound Mackie mixing desk (plus a Sampson DI box in the case of guitar and bass tracks).

Any idea what the MIDI problem is with the 32 bit version of Cubase? So far as I can see all the settings are the same in both versions but for some reason the 32 bit version is receiving but not passing on to a track, the input from the MIDI port on the Scarlett. I am reckoning that it must be an internal Cubase issue – either an incorrect setting on my part, or a software glitch. Am I missing something obvious?

All help and advice gratefully received.

Do you use WIndows or Mac? Do you have 32-bit driver of the Scarlett? Did you try to increase the Buffer size, when you are using 32-bit Cubase?

Try to check your Preferences > MIDI > MIDI Thru Activate. This should be activate (checked).
Screen Shot 2012-08-27 at 10.26.36.png

Sorry, I should have said that both machines are PCs running Windows 7, SP1.

Do you have 32-bit driver of the Scarlett?

So far as I am aware, the drivers are correct for both versions. Both Cubase versions are seeing the Scarlett and working correctly in all respects other than the MIDI problem which I described.

Did you try to increase the Buffer size, when you are using 32-bit Cubase?

No, what should the buffer size nominally be for each version, and how do I reset?

Try to check your > Preferences > MIDI > MIDI Thru Activate> . This should be activate (checked).

I will go and do this now.

The Buffer Size depends on your computer power (as a system, all components together), developer’s ASIO driver, and number and exact type of plug-ins, which you are using. Just try to change it.

The buffer size is controlled through the Scarlett’s software. I had it set for 5.0ms, which gave acceptable latency times of 11.338ms (input), 16.349ms (output). I reset the Scarlett at 15ms, which gave me whopping and unusable latencies of 31 and 46ms respectively. This had no effect whatsoever on the 32-bit MIDI input problem.

I do not think that the issue is the power of either PC. Both are relatively new and high specced multi core machines which were peviously running Cubase 5.0 and Cubase 6.0 quite happily, and which still run the 64-bit version fine. Nor am I overloading any tracks with plugins. I also checked out the Scarlett drivers - they are all located in Windows 7’s System 32 folder, which means I think that they are native 32-bit drivers which are equally compatible with the 64-bit version of Cubase, which I am running without difficulty.

The issue seems to me to be something which is happening in the 32-bit version of Cubase 6.5 but not in the 64-bit version which means that although the information from my keyboard controller is successfully passing through the Scarlett’s MIDI port into Cubase, it is not for reasons unknown passing into the actual armed track.

OK, what about the MIDI Thru Activate? Does it work?

It was already checked and doesn’t appear to make any difference to the problem.

Next to the “record arm” button there is another small button (like a speaker sideways) the “monitor” button.
Is that on?

Yep, I have tried that monitor button both ways, thanks - off and on. Neither makes any difference - I still can’t hear any input from the keyboard controller. Nor am I getting the blue lines next to the track which would show incoming activity to the track. The data is clearly just not getting there.

I can get data in via the software keyboard from the Halion or whatever’s edit screen. But I just can’t get anything physical at all from the MIDI port. And as I say, this only applies to the 32-bit version although that and the 64-bit version are set up the same, with the same hardware.

I am at something of a loss with this one - very frustrating. I suppose I could always work in 64-bit, but to be honest I am struggling to find any real advantages there other than that a fair number of my 32-bit plug-ins don’t work in 64-bit. Oops, that’s not an advantage, is it? :mrgreen:

I’d check the whole chain starting from the keyboard end.
I suspect that the problem lies somewhere between the Soundcard’s Control Panel and The midi settings in Cubase’s Device Setup and there to the input setting in the Inspector.

I’ve done all that several times and unless I am missing something really obvious (which is not impossible) the settings right along the chain are the same for both the 32- and the 64-bit versions. The 64-bit version works as it should. The 32-bit version doesn’t. The situation is replicated on two separate PCs.

I will go and double-check it all again, but I still reckon that the problem/misconfiguration has to be within Cubase itself.

Try to tresh your preferences.

Just rereading your original post and making sure. The 32 bit is not working on both machines? And while running the 32 bit the 64 bit version is definitely off?

Yes and yes, thanks. So far as I am aware there is no reason why one cannot install and run both versions on the same machine, though presumably running them both concurrently would be a bad idea.

It is not something which I have tried to do and I cannot think of a reason why anyone would want to do that.

Martin, my preferences are set the same for both versions so far as I know. I will re-check that but I cannot think of any MIDI (or other) settings which would result in the application not passing on incoming MIDI data - which is definitely reaching the application because I can see the orange line bouncing in the transport window - to its intended track.

In Cubase’s Device Setup / Midi are there any midi connections listed as inactive that should be active?

No, the MIDI into and out from the Scarlett are both shown as present and active.

The problem is not between the audio interface and the PC but within Cubase itself. I can see from the red line in the Transport window that Cubase is receiving MIDI input ok from my keyboard controller. But in the 32-bit version, that input is not being transmitted onwards to the actual track in record mode. It is however finding its way on to the track and recording properly in the 64-bit version.

Incidentally in both the 32- and 64-bit versions, data generated from, say, Halion’s own integral keyboard (or that of any other VST instrument - I tried this with several soft synths) is not being recorded on the actual track (and not showing as MIDI output in the Transport window) although I can hear output fine when I “play” the keyboard or pads with the mouse.

Seems to me that this must have something to do with the signal routing within Cubase. It’s a mystery :confused: