MIDI input sounds transposed

Greetings.

I have been using Dorico in the past weeks, and I’ve finally decided it’s time to get it full. But I have an issue. When I connect my MIDI device to Dorico, everything seems to work properly, but the resulting sound when I play on my keyboard is transposed. When I play C, D sounds. The same happens with all the other notes. However, my pitch bend is set to neutral, and everything else seems to be OK. I don’t know where the trouble may come from. I’d be glad if you could help me.

Cheers,
Héctor

Are you using transposing instruments (e.g. woodwinds/brass)? If you create a new project from piano template, same issue?

No, I’m not using tranporting instruments, and yes, it happens with any project that I open…

Please do following: Start a new project from piano template, double click on the stave to start note input, play on your keyboard C-D-E-F-G and then choose from Dorico’s main menu ‘Help > Create Diagnostics Report’. The corresponding zip file please attach to a reply here. Thanks

It sounds like maybe you have a mismatched sample rate, Héctor. Can you try going to Edit > Device Setup, choosing a different sample rate than the one showing as chosen, then waiting a second, and then re-choosing the original value again. That might sort things out.

Excuse me for the delay.

I’ve done what you both suggested. Here is the diagnostics report file, find it attached to this message. But when I tried choosing a different sample rate, only one appeared in the list (48000). I also upload the screenshot here so you can see it.
Dorico Diagnostics.zip (389.4 KB) screenshot

As Daniel said, then there must be a sample rate mismatch. If you have only 48kHz as choice, then the driver is in exclusive mode. Please try instead the free FlexASIO driver (Releases · dechamps/FlexASIO · GitHub) and report back. FlexASIO uses always share mode.

I’ve installed the FlexASIO driver and tried to do what Daniel suggested, but didn’t solve the problem. Choosing other sample rates didn’t work either.

I have a setting on my (ancient) DX7 that can transpose the output of the keyboard (independently of the pitch wheel). Is there a chance your keyboard has something similar that has been reset?

I just reset all my keyboard settings to default and it’s been finally solved. Seems like there was some kind of transposition option going on. Thank you!