MIDI Input stopped working

Cubase 12 Pro / Novation Launchkey Mini.
I’m using the Mini quite often but today it did not work, Studio Setup said “disconnected”. I tried to restart Cubase -not any better, a clean reboot and Cubase the first program to start, I tried to un-/replug USB cable (which cured the issue in the past) but to no avail.
After some fiddling I desperately started Cubase 12 Elements on an older project - worked!
Then closed that and restarted Cubase 12 Pro and now that works, too!
I don’t like things to behave like that, that was a real time waster.
Any ideas what happened and how to prevent that in the future?
Thank you.

PC or Mac?

If PC when it wasn’t working did you check in device manager to see if it was there? If this happens again check there first. It may be missing which points to a problem with the device or cable and not Cubase. It’s not usually a Cubase fault when a device does not show.


You can see the currently connected devices on Mac too.

I agree with mkok.

PC. Thanks for the hint.

It happened during a work session when I switched between Dorico and Cubase. The Mini worked in Dorico before. I then close Dorico and switch over to Cubase.

The weird thing is, as I described, it did not recover after a reboot, it required Cubase Elements to run its start-up sequences.